Fonction SI et ET avec plusieurs conditions [Résolu]

- - Dernière réponse : Vaucluse
Messages postés
24412
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 septembre 2019
- 28 juil. 2019 à 13:33
Bonjour,

Je souhaite faire une formule assez complexe mais Excel n'en veut pas.

Voici ma formule :
=SI(ET(D2="A";G2="A";43;SI(ET(D2="B";G2="B";0;SI(ET(D2="A";G2="B";38;SI(ET(D2="B";G2="A";5;))))))))

En français ça donne :
Si D2 = A et G2 = A, la cellule affiche 43
Si D2 = B et G2 = B, la cellule affiche 0
Si D2 = A et G2 = B, la cellule affiche 38
Si D2 = B et G2 = A, la cellule affiche 5

Savez-vous pourquoi cela ne fonctionne pas ?

Merci par avance !
Afficher la suite 

3 réponses

Messages postés
24412
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 septembre 2019
4772
0
Merci
Bonjour
... parce qu'il faut grouper les "ET" entre parenthèses, enlever au bout celles qui seront donc en trop, et éventuellement rajouter à la fin ;"" ce qui permettra d'éviter l'affichage de FAUX si aucune option n'est trouvée (sinon le point-virgule final est de trop)


=SI(ET(D2="A";G2="A");43;SI(ET(D2="B";G2="B");0;SI(ET(D2="A";G2="B");38;SI(ET(D2="B";G2="A");5;""))))

crdlmnt
Commenter la réponse de Vaucluse
0
Merci
Merci beaucoup !

Je galérais depuis hier soir sur cette formule et je ne trouvais aucune réponse en ligne

Bonne journée !
Commenter la réponse de Greg
Messages postés
24412
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 septembre 2019
4772
0
Merci
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse