Somme cellule identique [Résolu]

Messages postés
27
Date d'inscription
vendredi 24 avril 2015
Statut
Membre
Dernière intervention
26 juillet 2019
-
Bonjour à tous.
Dans une feuille excel, j'ai une liste de lignes avec 3 colonnes.
site reference qté mvt
1 450 - 1
1 494 2
1 494 2
1 2081 1
1 2086 1
1 2493 - 1
1 2493 1
Je souhaite afficher dans la colonne 4 la somme des qté mvt pour chaque référence, soit
site reference qté mvt Total
1 450 - 1 - 1
1 494 2
1 494 2 4
1 2081 1 1
1 2086 1 1
1 2493 - 1
1 2493 2
1 2493 2 3
Merci de votre aide.
Bonne fin de semaine.
Afficher la suite 

3 réponses

Messages postés
24585
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 octobre 2019
4830
0
Merci
Bonjour
que voulez vous, ,la somme où les résultats cote à cote comme dans votre message?
à vous lire
crdlmnt
CETIFA
Messages postés
27
Date d'inscription
vendredi 24 avril 2015
Statut
Membre
Dernière intervention
26 juillet 2019
-
En prenant l'exemple de la référence 2493 qui comporte 3 lignes, je souhaite que le résultat des cellules C1+C2+C3 de ces 3 lignes (soit 3) soit renseigné dans le cellule D3.
En vous remerciant par avance de votre aide,
Bonne soirée.
Commenter la réponse de Vaucluse
0
Merci
Bonjour à tous,

Une solution simple consiste à copier la liste des références dans une autre colonne puis de supprimer les doublons dans cette nouvelle liste.
Exemple :
Avec les références initiales en B2:B8, les quantités en C2:C8, la nouvelle liste en F2:Fx, la formule suivante donne la somme des quantités de mouvement pour chaque référence.
=SOMME.SI($B$2:$B$8;$F2;$C$2:$C$8)

Cordialement.
Commenter la réponse de gyrus
Messages postés
24585
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 octobre 2019
4830
0
Merci
Re
pour sommer en continu en colonne D en commençant en ligne 2

=SOMME.SI($B$2:B2;B2;$C$2:C2)

qui donnera la somme à la hauteur de la formule
et pour n'avoir la somme que sur la 1°ligne ou apparaît le code:

=SI(NB.SI($B$2:B2;B2)=1;SOMME.SI(B:B;B2;C:C);"")

attention aux $ aux bons endroits
crdlmnt

CETIFA
Messages postés
27
Date d'inscription
vendredi 24 avril 2015
Statut
Membre
Dernière intervention
26 juillet 2019
-
Cela est parfait.
Il vaut mieux 1 qui sache que moi qui cherche.
Merci de votre aide.
Bon WE
Vaucluse
Messages postés
24585
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
16 octobre 2019
4830 -
alors on passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse