Excel - formule qui ne fonctionne pas

Messages postés
67
Date d'inscription
mardi 31 juillet 2007
Statut
Membre
Dernière intervention
13 août 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
49649
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 août 2019
- 13 août 2019 à 15:19
Bonjour,

Je n'arrive pas à faire ma formule sur Excel.
Voici en mots ce que je souhaiterais faire:
si la durée (qui se trouve en colonne M est comprise entre 2 et 5 jours alors afficher 2, si comprise entre 6 et 12 jours alors afficher 3, si supérieure à 12 jours alors afficher 4

Voici ce que j'ai écris et qui fonctionne sauf pour la dernière condition, si supérieur à 12 qui ne fonctionne pas.
=SI(M5=2;2;SI(M5=3;2;SI(M5=4;2;SI(M5=5;2;SI(M5=6;3;SI(M5=7;3;SI(M5=8;3;SI(M5=9;3;SI(M5=10;3;SI(M5=11;3;SI(M5=12;3;SI(M5=>13;4;FAUX))))))))))))

J'ai essayé avec une formule SI ET pour plus de simplicité mais ce ne fonctionne pas non plus:
=SI(ET(M2="2";M2="3";M2="4";M2="5");2;FAUX)

merci :)
charlene
Afficher la suite 

3 réponses

Messages postés
24301
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 août 2019
4726
0
Merci
Bonjour
=SI(M2<2;"";SI(M2<=5;2;SI(M2<=12;3;4)))
devrait suffire
ou peut être selon ce que contient M2
=SI(ET(M2>=2;M2<=5);2;SI(M2<=12;3;SI(M2>12;4;"")))
crdlmnt

Commenter la réponse de Vaucluse
Messages postés
67
Date d'inscription
mardi 31 juillet 2007
Statut
Membre
Dernière intervention
13 août 2019
0
Merci
Merci beaucoup !!!!!
Commenter la réponse de charlene1501
Messages postés
49649
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 août 2019
10464
0
Merci
Bonjour Charlène.

Ta première formule contient, à la fin, un opérateur qu'Excel ne connaît pas !
Remplace
=>
par
>=
et ça devrait marcher ...
Profites-en pour remplacer
FAUX
par
""
...

Ta deuxième formule signifie :
Si M2 est égale à la fois (en même temps) à 2, 3, 4 et 5 alors afficher 2 ! Avoue que c'est difficile (même en physique quantique).
Commenter la réponse de Raymond PENTIER