Videos ne lisant pas les sous-titres non incrustés [Résolu]

Messages postés
35
Date d'inscription
dimanche 4 novembre 2007
Statut
Membre
Dernière intervention
10 septembre 2019
- - Dernière réponse : jeannets
Messages postés
16225
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
16 octobre 2019
- 13 juil. 2019 à 22:30
Bonjour,
J'ai quelques vidéos au format mkv en anglais,en japonais et en chinois.
Ce type de fichier passe difficilement.
J'ai donc extrait les sous-titres en français (si il y en avait) et les ai transformés en srt par Subtitle Edit (très bon logiciel);et en ass
Quant aux vidéos,j'ai extrait les pistes images et sons - en VO - que j'ai transformés en mp4.
Pour d'autres,qui ne contenaient pas de sous-titres,j'ai cherché des sous-titres sur Google;j'en ai trouvé pour la plupart,en français ou en anglais.Jes ai tous mis en srt (SE).Les vidéos,je les ai mises en mp4,si ce n'était pas déjà le format.
Mais voilà,certains mp4 ne lisent pas les srt.Même avec Vlc et d'autres lecteurs.
J'ai pensé d'abord que les srt n'étaient pas conformes.Mais en les mettant avec une autre vidéos,ils étaient parfaitement lus.Donc les srt ne sont pas à incriminés.Les coupables sont donc les vidéos.
J'ai ré-encodé les vidéos,soit encore en mp4,soit en avi.Aucun résultat.
Qu'est-ce qu'il peut y avoir dans les vidéos qui les empêche de lire les srt (et les ass)?
J'espère que quelqu'un pourra éclaircir pour moi ce mystère.
Cordialement


Configuration: Windows / Firefox 68.0
Afficher la suite 

2 réponses

Messages postés
16225
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
16 octobre 2019
1709
0
Merci
Bonjour,

Je crois qu'intégrer les sous-titres en MP4, ça ne marche pas bien...

Il faut savoir si les sous titres font parte de la vidéo... ou si tu lis deux fichiers simultanément Donc le texte et la Vidéo et c'est VLC qui fait le mélange..??

Il faudrait que tu donne le fichier "MediaInfo" d'une de ces vidéo (au format texte) et de préférence avant d'etre modifié en MP4... C'est quoi le format d'avant..? Le type d'encodage..?? l'AVI n'est pas un encodage, c'est un container.
Commenter la réponse de jeannets
Messages postés
35
Date d'inscription
dimanche 4 novembre 2007
Statut
Membre
Dernière intervention
10 septembre 2019
2
0
Merci
Bonjour.
Oui!Je sais que avi n'est pas un format.Mais pour moi,quand je pense avi,je pense à mp3 et mpeg (ou xvid ou divx).
Mais il est vrai que lorsque j'ai réencodé le fichier mkv,je n'ai pas fait attention;et en vérifiant je vois que j'ai réencodé avec mpeg-4 visual (xvid) et mp3.Peut-être faut-il essayer avec mpeg-1 ou 2?Je verrai ça demain.
Pour fichier qui ne lit pas les sous-titres,je ne vois pas comment je peux joindre un fichier texte;une image,oui,mais pas txt.Je vais donc mettre un copier-coller,ci-après.
Je remarque que,en exportant le résultat de mediainfo,figure un identifiant unique;lequel ne figure pas dans la fenêtre basique de mediainfo.
Je vérifierai demain si les autres fichiers,compatiples ou non avec les st,ont également un code d'identification unique.
Cordialement
et voici le résultat de mediainfo (c'est un peu long):

Général
Identifiant unique : 58897782504102378073206706936704865762 (0x2C4F4CE058DE66BCD06FF612F8AB15E2)
Nom complet Western-Rio Lobo 1970.mkv
Format : Matroska
Version du format : Version 4
Taille du fichier : 3,46 Gio
Durée : 1 h 54 min
Débit global moyen : 4 326 kb/s
Date d'encodage : UTC 2019-07-05 10:40:02
Application utilisée : mkvmerge v35.0.0 ('All The Love In The World') 64-bit
Bibliothèque utilisée : libebml v1.3.9 + libmatroska v1.5.2

Vidéo
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Profil du format : High@L3.1
Paramètres du format : CABAC / 4 Ref Frames
Paramètres du format, CABAC : Oui
Paramètres du format, RefFrames : 4 images
Identifiant du codec : V_MPEG4/ISO/AVC
Durée : 1 h 54 min
Débit : 1 500 kb/s
Largeur : 1 080 pixels
Hauteur : 600 pixels
Format à l'écran : 16/9
Type d'images/s : Constant
Images par seconde : 23,976 (24000/1001) Im/s
Espace de couleurs : YUV
Sous-échantillonnage de la chrominance : 4:2:0
Profondeur des couleurs : 8 bits
Type de balayage : Progressif
Bits/(Pixel*Image) : 0.097
Taille du flux : 1,20 Gio (35%)
Bibliothèque utilisée : x264 core 149 r2802M 8c29742
Paramètres d'encodage : cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=4 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=2 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=1 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=20 / rc=abr / mbtree=1 / bitrate=1500 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Default : Oui
Forced : Non

Audio
ID : 2
Format : PCM
Paramètres du format : Little / Signed
Identifiant du codec : A_PCM/INT/LIT
Durée : 1 h 54 min
Type de débit : Constant
Débit : 2 822 kb/s
Canaux : 2 canaux
Echantillonnage : 44,1 kHz
Images par seconde : 5,000 Im/s (8820 SPF)
Profondeur des couleurs : 32 bits
Taille du flux : 2,25 Gio (65%)
Langue : Anglais
Default : Oui
Forced : Non
jeannets
Messages postés
16225
Date d'inscription
dimanche 9 septembre 2007
Statut
Contributeur
Dernière intervention
16 octobre 2019
1709 -
OK, J'ai l'impression que ce N° d'identification provient d'un Blue Ray qui devait etre à l'origine de ce fichier...

-- Ton média info est bien, Perso, j'aurais un peu diminuer les fréquences et Bitrate, mais bon, c'est toi que ça regarde si tu veux améliorer tes images, ça te fera juste un fichier un peu plus gros, c'est tout.
Donc ta vidéo fonctionne avec l'audio en Anglais.

-- Par contre je ne vois pas la partie sous titrage dans le fichier..? que j'ai dit texte pour les formats .srt, .ssa ou .sub. qui contiennent un timming... J'en conclu que tu lis ce fichier en même temps que la vidéo ?

-- Voici une liste de logiciel pour le sous titrage.. https://www.atenao.com/blog/outils-sous-titrage/logiciels-de-titrage/
Perso, j'utilise pas mal AVIdemux pour du 64 bits..(gratuit et assez puissant). il fonctionne mieux sous Linux... il réencode une vidéo tout en lui intégrant un fichier de sous titrage

.... Vidéo Output===>Filter==>Subtitle===>Double clic sur SSA SRT ASS... il te demande le fichier de sous titrage. ici tu trouvera ton bonheur https://www.opensubtitles.org/en/search/sublanguageid-all/idmovie-10853
Dans ta "Hauteur d'image" Hauteur : 600 pixels tu devrais mettre 604, cette valeur doit etre divisible par 8..

-- Une autre idée serait de démuxer ta vidéo de son container MKV à l'aide de TSmuxer qui fait très bien ça.. http://www.hdfever.fr/2009/09/01/tsmuxer-manipulations-muxe-et-demuxe-de-containers-mkv-mka-mpeg-ts-mov-ou-mp4/ il y a une explication et plus bas, un lien vers un tutoriel...
Et ensuite tu réencode en MP4 avec AVIdemux en introduisant ton fichier de sous titres... Je sais, ce n'est pas tout simple... Mais ton sous titrage qui coince, c'est en raison d'un défaut de synchro de la vidéo...

Disons aussi qu'il faut faire des essais... Because via Forum, on ne vois rien..
Commenter la réponse de eric1000