Menu

Comment insérer à une formule si une cellule vide ne pas appliquer la formule [Résolu]

Messages postés
5
Date d'inscription
vendredi 12 juillet 2019
Statut
Membre
Dernière intervention
16 juillet 2019
- - Dernière réponse : pasck31
Messages postés
5
Date d'inscription
vendredi 12 juillet 2019
Statut
Membre
Dernière intervention
16 juillet 2019
- 16 juil. 2019 à 00:34
Bonjour,
J'essaie d'appliquer à la formule suivante =SI(ET(E4<>"";E4<D4);NB.JOURS.OUVRES(D4;E4);NB.JOURS.OUVRES(D4;SI(OU(E4="";E4<D4);AUJOURDHUI();E4))+1) la condition ESTVIDE(A4);"";
Mais ça ne fonctionne pas.
J'ai pu le faire pour cette formule =SI(ESTVIDE(A4);"";ENT(MOD(F4;365)/30) & " mois " & MOD(F4;365)-(ENT(MOD(F4;365)/30)*30) & " jour(s)").

Merci de votre aide.
Afficher la suite 

8 réponses

Messages postés
49372
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
10270
0
Merci
Ta formule est trop fantaisiste : =SI(ET(E4<>"";E4<D4) ... signifie
si la date de fin est antérieure à la date de début
, donc
si on finit avant d'avoir commencé
, et NB.JOURS.OUVRES(D4;E4) donne une durée négative !
Ensuite tu ne vérifies pas si D4 et E4 sont bien antérieures à aujourd'hui ... Donc au lieu de
SI(OU(E4="";E4<D4);AUJOURDHUI();E4)) j'aurais mis
SI(OU(D4>AUJOURDHUI();E4>AUJOURDHUI());""; SI(OU(E4="";E4>AUJOURDHUI());AUJOURDHUI();E4)) )

Et je n'ai pas compris ce qui suit
la condition ESTVIDE(A4);""; 

Commenter la réponse de Raymond PENTIER
Messages postés
5
Date d'inscription
vendredi 12 juillet 2019
Statut
Membre
Dernière intervention
16 juillet 2019
0
Merci
Bonjour Raymond, merci pour ta réponse.

En appliquant ta formule j'ai un pop-up m'indiquant une erreur en me proposant de la corrigée, mais lorsque je clic ok pour correction le résultat pour date de début 01/01/2019 et date de fin 01/02/2019 est de 43497 jours. Avec ma formule 25 jours.
Je veux calculer le nombre de jours ouvrés entre la date de début en (D4) et la date de fin en (E4) et si il n'y a pas de date de fin il faut que le calcule se fasse avec la date du jour, et ajouter la condition que si (A4) vide pas de calcul.

Merci pour ton aide.

PS: la vi la bel an ba la ?
Commenter la réponse de pasck31
Messages postés
24209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681
0
Merci
Bonjour
je ne crois pas que la formuler vous renvoie 43947 en valeur de la différence, mais la date en standard Excel. Ce qui, dans un format date, vous donne le 26/04/2020
formatez votre cellule en date pour voir
pour avoir ce que vous voulez, précisez ce que vous attendez de cette formule par rapport aux cellules de référence!
crdlmnt

Commenter la réponse de Vaucluse
Messages postés
5
Date d'inscription
vendredi 12 juillet 2019
Statut
Membre
Dernière intervention
16 juillet 2019
0
Merci
Bonjour,
Voilà, dans un tableau Excel je veux mettre en cellule A1 une référence de facture en B1 le statut de la facture en C1 la date de début D1 la date de fin, en E1 le calcul du nombre de jours ouvrés si D1 vide calcul avec la date du jour à condition que A1 non vide, puis en F1 convertir le résultat de E1 en mois et jour.
En espérant avoir été clair, merci.
Commenter la réponse de pasck31
Messages postés
24209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681
0
Merci
Re
en E1
=SI(A1="";"";NB.JOURS.OUVRES(C1;SI(D1="";AUJOURDHUI();D1))
En F1, vous ne pouvez pas convertir le résultat en mois et jour, puisqu'il s'agit d'un résultat indépendant des longueur de mois, du nombre de jours de WE etc...

vous pouvez seulement définir en F1 un nombre de mois et de jours incluant tous les jours avec cette formule:
=DATEDIF(C1;SI(D1="";AUJOURDHUI();D1);"m")&"mois "&DATEDIF(C1;SI(D1="";AUJOURDHUI();D1);"md")&" jours"

si vous voulez autre chose en F, revenez mais expliquez comment v ous voyez ça

en aparté: vous pouvez compléter la formule NB.JOURS.OUVRES avec un champ reprenant les dates de jours fériés
=NB.JOURS.OUVRES(début;fin;champ des jf)

Commenter la réponse de Vaucluse
Messages postés
5
Date d'inscription
vendredi 12 juillet 2019
Statut
Membre
Dernière intervention
16 juillet 2019
0
Merci
Merci Vaucluse,
En appliquant =SI(A1="";"";NB.JOURS.OUVRES(C1;SI(D1="";AUJOURDHUI();D1))
J’ai un pop-pi m’indiquant qu’il manque une parenthèse.

Et pour le résultat en F1 je le convertis avec la formule suivante que j’ai trouvé sur le net
=SI(ESTVIDE(A4);"";ENT(MOD(F4;365)/30) & " mois " & MOD(F4;365)-(ENT(MOD(F4;365)/30)*30) & " jour(s)") mais avec une d’if de -1jours (pas trop grave, il suffit juste que je m’en rappelle ).

Merci, si tu peux corriger la formule en y ajoutant la parenthèse, moi je ne suis pas terrible en bureautique.
Bonne journée,
Cdlt: pasck31
Commenter la réponse de pasck31
Messages postés
24209
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681
0
Merci
il suffit de la rajouter à la fin de la formule, il en faut 3
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
5
Date d'inscription
vendredi 12 juillet 2019
Statut
Membre
Dernière intervention
16 juillet 2019
0
Merci
Bonjour Vaucluse,
le souci venait de ma feuille de calcule, je l'ai donc modifié et ça marche, le calcule pour les jours ouvrés est correcte et dans une autre cellule j'ai appliqué mon autre formule, pour convertir le totale des jours ouvrés en mois/jours et ça marche comme je le voulais. Merci de ton aide et à bientôt.

cordialement,

Pasck97
Commenter la réponse de pasck31