Menu

Problème upgrade

- - Dernière réponse :  salade - 13 juil. 2019 à 10:07
Bonjour,
Bonjour,

J'ai un raspberry pi3 et je suis complètement novice.

J'ai un souci avec la commande "sudo apt-get dist-upgrade".

En effet, le message suivant s'affiche et je suis perdue.

Je vous remercie d'avance pour votre aide pour comprendre et remédier à ce problème.

"sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libsdl1.2-dev : Dépend: libcaca-dev mais il n'est pas installé
Dépend: libdirectfb-dev (>= 0.9.22) mais il n'est pas installé
Dépend: libglu1-mesa-dev mais il n'est pas installé ou
libglu-dev
Dépend: libpulse-dev mais il n'est pas installé
Dépend: libxext-dev mais il n'est pas installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
XXXXXX :~ $ apt-get -f install
bash: apt-get : commande introuvable"


Configuration: Macintosh / Safari 6.0
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
36609
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
13 juillet 2019
3691
2
Merci
Salut,
XXXXXX :~ $ sudo apt-get -f install
;-))

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 54150 internautes nous ont dit merci ce mois-ci

Commenter la réponse de zipe31
0
Merci
Bonjour,

J'ai encore des problèmes à ce sujet..

Voici le message qui s'affiche après avoir rectifié la commande :

XXXXXXX:~ $ sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
libsdl1.2-dev : Dépend: libcaca-dev mais il n'est pas installé
Dépend: libdirectfb-dev (>= 0.9.22) mais il n'est pas installé
Dépend: libglu1-mesa-dev mais il n'est pas installé ou
libglu-dev
Dépend: libpulse-dev mais il n'est pas installé
Dépend: libxext-dev mais il n'est pas installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
zipe31
Messages postés
36609
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
13 juillet 2019
3691 -
Re-

L'installation est récente de ton raspberry ? (si oui, peut-être serait-il plus raisonnable de repartir sur une installation saine ?)

Qu'as-tu installé pour en arriver là ?
Merci pour ton aide..

Comme on me l'a offert, je ne sais pas ce qui a été fait avant.
Commenter la réponse de salade