Multiplier une cellule en fonction d'une chaine de caractère [Résolu]

Signaler
Messages postés
2
Date d'inscription
mardi 9 juillet 2019
Statut
Membre
Dernière intervention
8 décembre 2019
-
Pyxhel
Messages postés
2
Date d'inscription
mardi 9 juillet 2019
Statut
Membre
Dernière intervention
8 décembre 2019
-
Bonjour,

Je souhaiterais que ma colonne C multiplie par 100 la colonne B si elle trouve « JPY » dans la chaine de caractère de la colonne A sachant que la chaine entière serait USD/JPY et multiplie par 10 000 si elle ne trouve pas « JPY ».

En entrant cette formule: SI(CNUM(CHERCHE("JPY";A1));B1×100;B1×10000) j’ai réussi à ce que C1 renvoie 200 (car B1 = 2 et A1 = « USD/JPY » ) mais lorsque j’étends la formule sur C2 la fonction fait erreur et mentionne: "CHERCHE n’a pas pu trouver la valeur « JPY »" (car A2 = «USD/CAD»)


Quelqu'un saurait m’aider à avoir C2 qui renvoie 20 000 ?

Merci

PS: j'utilise Number sur MacOS mais il me semble que les fonctions sont à peu près similaires que celles de MS Excel.

2 réponses

Messages postés
21
Date d'inscription
dimanche 8 décembre 2019
Statut
Membre
Dernière intervention
19 décembre 2019
1
Bonjour mon pote
Je pense que vous avez compliquer un peu les choses :)
Je vous invite à essayer cette formule:
=SI(DROITE(O20;3)="JPY";P20*100;P20*10000)
(explication: si(la droite cellule A à 3 caractères est égal à "JPY"; alors cellule B*100; sinon cellule B*10000).
mka_3404
Messages postés
21
Date d'inscription
dimanche 8 décembre 2019
Statut
Membre
Dernière intervention
19 décembre 2019
1
Malheureusement j'ai pas vu votre question plutôt.
Messages postés
2
Date d'inscription
mardi 9 juillet 2019
Statut
Membre
Dernière intervention
8 décembre 2019
1
Pas de soucis ! Merci cette formule fonctionne parfaitement :)
En revanche, j'ai eu le temps d'en trouve une autre entre temps, la voici:

=IF(ISERROR(SEARCH("JPY";C9));D9*10000;D9*100)

en français ça donne:

=SI(ESTERREUR(CHERCHE("JPY";C9));D9*10000;D9*100)

C9 étant la chaîne de caractère et D9 la valeur à multiplier.