Date d'aujourdhui

Messages postés
90
Date d'inscription
samedi 19 novembre 2016
Statut
Membre
Dernière intervention
7 juillet 2019
- - Dernière réponse : PapyLuc51
Messages postés
1994
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 juillet 2019
- 8 juil. 2019 à 18:33
Bonjour,
Quel est la formule pour demander par exemple :
=SI(DATE(AUJOURDHUI(JOUR= 28 "du mois"; A1 + A2; "")))

merci pour votre temps
Afficher la suite 

3 réponses

Messages postés
24217
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2019
4684
0
Merci
Bonjour

=SI(JOUR(AUJOURDHUI()=28;A1+A2;"")

donnera A1+A2 tous les 28 selon le mois en cours, mais cette formule est volatile et le résultat disparaîtra le lendemain!
peut être vaudrait il mieux écrire:

=SI(AUJOURDHUI()>DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());28);A1+A2;"")

qui conservera A1+A2 dés que le 28 sera dépassé

crdlmnt

Amnexia
Messages postés
90
Date d'inscription
samedi 19 novembre 2016
Statut
Membre
Dernière intervention
7 juillet 2019
-
Salut et merci, ça donne déjà un résultat
j'ai modifié un peu et la fonction donne le résultat attendu mais comment savoir si ça fonctionnera tout les mois et comment faire pour incruster dans une cellule mensuellement ?

La fonction :

=SI(AUJOURDHUI()>DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());JOUR(AUJOURDHUI()) = B10); F10+S32; "")


Disons que :
B10 = 28
F10 = 50€
S32 = 10.000€

Tout les mois la cellule S32 augmentera de 50€ ( si j'actualise la page le jour B10 ) 10.050€ puis 10.100€ etc etc..
Raymond PENTIER
Messages postés
49389
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 juillet 2019
10292 -
"Tout les mois la cellule S32 augmentera de 50€" c'est impossible (sauf si tu sais écrire des macros) ...
Commenter la réponse de Vaucluse
Messages postés
24217
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2019
4684
0
Merci
Si vous expliquez mieux ce que vous voulez obtenir d'un mois sur l'autre, on pourra peut être compléter.


Commenter la réponse de Vaucluse
Messages postés
1994
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 juillet 2019
383
0
Merci
Bonjour,

Une possibilité (références cellules à rectifier)

A2 - une date de départ
B2 - le jour de bascule soit le 28
C2 - le montant de départ soit 10000
D2 - Ajout mensuel soit 50

=C2+D2*(DATEDIF(DATE(ANNEE(A2);MOIS(A2);B2);AUJOURDHUI();"m"))

Remettre le format de cellule en nombre après avoir entré cette formule

Pour une date de départ au 1/1/19 ça fait 10250 et ça passera à 10300 le 28 juillet

Cordialement
PapyLuc51
Messages postés
1994
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 juillet 2019
383 -
Re:

Dans mon exemple s'il faut déjà ajouter 50 dès le 28 janvier alors la formule est à modifier

=C2+D2*(DATEDIF(DATE(ANNEE(A2);MOIS(A2);B2);AUJOURDHUI();"m")+1)

Cordialement
Commenter la réponse de PapyLuc51