Si tel ou tel mot est présent

- - Dernière réponse :  Nico - 4 juil. 2019 à 17:34
Bonjour,

Je cherche la formule à plusieurs conditions et plusieurs réponses donc.
voici3 exemples de texte de la cellule
- 2019|Q2|NCA|NR|EP|GTS_TONTON|BEL_JTCS|PAR|FRA
- 2019|Q2|NCA|NR|EP|GTS_TATA|BEL_JTCS|PAR|FRA
- 2019|Q2|NCA|NR|EP|GTS_MAMAN|BEL_JTCS|PAR|FRA

Je sais faire la formule si tel mot est présent alors je met ce texte
ici le texte présent étant TONTON alors je mets TONTON dans la colonne où se situe la formule
=SI(OU(ESTNUM(CHERCHE("TONTON";H3));H3="");"TONTON";"NON")

Mais je voudrais donc une formule qui fait:
- s'il y a TONTON alors écrire TONTON
- s'il y a TATA alors écrire TATA
- s'il y a MAMAN alors écrire MAMAN

Merci de votre aide
Afficher la suite 

2 réponses

Messages postés
186
Date d'inscription
samedi 19 mars 2011
Statut
Membre
Dernière intervention
12 août 2019
24
0
Merci
Bonjour,

Voici la ligne pour TONTON ou TATA ou MAMAN :
=SI(OU(ESTNUM(CHERCHE("TONTON";H3));H3="");"TONTON";SI(OU(ESTNUM(CHERCHE("TATA";H3));H3="");"TATA";SI(OU(ESTNUM(CHERCHE("MAMAN";H3));H3="");"MAMAN";"NON")))

A la place du "NON" qui correspond au "Sinon", il faut remettre la condition "SI(...."
Commenter la réponse de Fulsten
Commenter la réponse de Nico