Menu

Pourboire

Messages postés
13
Date d'inscription
mardi 2 juillet 2019
Statut
Membre
Dernière intervention
4 juillet 2019
-
Bonjour,
j'ai un probleme de formule.

jai un fichier excel je doit calculer le pourboire mais en meme temps le maximum pour le pourboire est 3$ sur 20$ et si la facture coute 15,64 on ne veut pas le 3$ maximum du 20$ faut que se soit le 15% maximum de la facture en bas de 20$ je sais pas si vous comprenez mais avec cette formule lorsque jai 15,64 sa ne fonctionne plus et le 28,69 et le 29,26 cest trop haut cest max 20$ que je paye. merci de votre aide.
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
1816
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 juillet 2019
667
1
Merci
Bonjour,

Si j'ai bien compris:
-Pour un montant inférieur à 20 $ => 15% de pourboire.
- Pour un montant = ou supérieur à 20$ => 3$

Est-ce bien ça?

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 54704 internautes nous ont dit merci ce mois-ci

fantas2282
Messages postés
13
Date d'inscription
mardi 2 juillet 2019
Statut
Membre
Dernière intervention
4 juillet 2019
-
regarde jai fait cela et sa fonctionne etrangement partout est ce possible davoir plus court la formule?? merci

=(SOMME.SI(B30:H30;"<3"))+(NB.SI(B30:H30;">=3")*3)+SI(B30<0,15*B29;B30-B30;B29*0,15-B30)+SI(F30<0,15*F29;F30-F30;F29*0,15-F30)+SI(C30<0,15*C29;C30-C30;C29*0,15-C30)+SI(E30<0,15*E29;E30-E30;E29*0,15-E30)+SI(D30<0,15*D29;D30-D30;D29*0,15-D30)+SI(G30<0,15*G29;G30-G30;G29*0,15-G30)+SI(H30<0,15*F29;H30-H30;H29*0,15-H30)
diablo13800
Messages postés
1816
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 juillet 2019
667 -
Bonjour,

J'ai distingué 4 cas dans votre problématique. Dites-moi si je me trompe avant de fournir la formule :)
Pb = Pourboire par la suite :)
- Cas 1 : Total <20 et Pb <15% => Doit additionner au total le Pb
- Cas 2 : Total <20 et Pb >15% => Doit additionner 15% du Total.
- Cas 3 : Total >20 et Pb < 15% => Doit additionner le Pb
- Cas 4 : Total >20 et PB > 15% => Doit additionner 3.

J'ai peur de rater un cas ou Total > 20 et Pb< 15% et Pb > 3 ... mais pas sur...

Est-ce ca?
fantas2282
Messages postés
13
Date d'inscription
mardi 2 juillet 2019
Statut
Membre
Dernière intervention
4 juillet 2019
-
oui sa ressemble a sa :)
diablo13800
Messages postés
1816
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 juillet 2019
667 -
Pouvez-vous essayer avec cette formule:
=SOMMEPROD((B30:H30>B29:H29*0,15)*(B30:H30<3)*(B29:H29*0,15))+SOMMEPROD((B30:H30<=B29:H29*0,15)*(B30:H30<3)*(B30:H30))+SOMMEPROD((B30:H30<B29:H29*0,15)*(B30:H30>3)*(3))+SOMMEPROD((B30:H30>B29:H29*0,15)*(B30:H30<3)*(3))
fantas2282
Messages postés
13
Date d'inscription
mardi 2 juillet 2019
Statut
Membre
Dernière intervention
4 juillet 2019
-
salut je ne sais pas comment se comporte cette formule mais lautre facon que jai marquer va mieux car si je met juste 1 endroit du tips sa me fait plus que 3$? mais je vais le laisser avec ma longue formule. merci de ton aide :)
Commenter la réponse de diablo13800