Menu

Permission non accordée - Clé USB [Résolu]

Messages postés
11
Date d'inscription
samedi 29 juin 2019
Statut
Membre
Dernière intervention
5 juillet 2019
-
Bonjour bonsoir,

J'ai actuellement un Raspberry Pi 3 B.

J'ai branché une clé usb dessus, et il m'est impossible de copié un fichier ou un dossier dedans.
(en root ça fonctionne, MAIS):

J'ai un serveur proftpd ouvert, et je veux mettre des fichier sur cette clé, mais je n'est pas les perms.


-J'aimerais savoir comment m'accorder tout les droits sur cette clé, avec tout les utilisateurs de la machine.

Merci d'avance :)
Afficher la suite 

1 réponse

Messages postés
28871
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
10 juillet 2019
6597
0
Merci
Bonjour,

Alors de manière générale ce n'est pas une bonne idée de données les droits à tout le monde sur une clé. De manière générale, seul l'utilisateur qui a monté la clé à des droits en écriture dessus, et c'est la bonne manière de faire. Quand on veut donner l'accès à plusieurs utilisateurs, on devrait plutôt définir un groupe qui rassemble les personnes qui ont accès à ladite clé.

Quoi qu'il en soit, toutes ces questions se résolvent au moment de monter la clé (cf commande
mount
), qui permet de spécifier l'utilisateur propriétaire de la clé, le groupe propriétaire, et les droits associés aux fichiers de la clé.

Dans ton cas, la clé sera identifiée par un device (par exemple
/dev/sdb1
, en admettant que
/dev/sda
corresponde à ton disque dur). Tu peux retrouver cette information avec la commande
sudo fdisk -l
.

Ensuite il faut créer un répertoire vide (point de montage) dans lequel apparaîtra la clé. Disons
/media/usb
.

sudo mkdir -p /media/usb


Puis on monte la clé, avec les bonnes options (encore une fois j'insiste : ceci n'est PAS une commande que je recommande, mais elle fait ce que tu demandes) :

sudo mount -o default,rw,user,dmask=000,fmask=111 /dev/sdb1 /media/usb


Pour plus de détails, voir
man mount
et ce lien pour comprendre les histoires de masques. En gros
dmask
, et
fmask
correspondent aux droits associés aux dossiers et aux fichiers réguliers.

Pour comprendre ce qui suit, lit au préalable
man chmod
de sorte à comprendre comment est définie la syntaxe octale utilisée par cette commande.

Les valeurs de masque correspondent au complémentaire (au sens mathématique) du masque qu'on passe à la commande
chmod
(donc par exemple appliquer
chmod 755
sur les dossiers revient à définir un
dmask
égal à
022
). Dit plus simplement,
mask_chmod + dmask = 777
. Le principe est le même pour
fmask
.

Bonne chance
Darkzor21
Messages postés
11
Date d'inscription
samedi 29 juin 2019
Statut
Membre
Dernière intervention
5 juillet 2019
-
Et bien.. Je vais encore passer 5H à apprendre de nouvelle chose. Merci ❤️
Darkzor21
Messages postés
11
Date d'inscription
samedi 29 juin 2019
Statut
Membre
Dernière intervention
5 juillet 2019
-
Bien merci mamiemando , j'ai réussi à le faire grâce à un forum d'ubuntu. J'ai juste copié 2-3 ligne dans le fichier /etc/fstab.

Pour la commande
sudo mount -o default,rw,user,dmask=000,fmask=111 /dev/sdb1 /media/usb
. J'ai regardé (et essayé de comprendre en même temps) les permissions, et j'ai vu que default pouvait poser problème, je l'ai donc retiré, et ça a fonctionné :D

Je redémarre le raspberry, et :) ça marche plus :-| Je suis retourné dans le fichier /etc/fstab pour enlever le default que je n'avais pas vu.

Maintenant c'est nickel.

Merci <3
mamiemando
Messages postés
28871
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
10 juillet 2019
6597 -
Félicitations et bonne continuation :-)
Commenter la réponse de mamiemando