Menu

Erreur ora-04043 malgre tout est ok

Messages postés
3
Date d'inscription
vendredi 26 octobre 2018
Statut
Membre
Dernière intervention
29 juin 2019
- - Dernière réponse : Xavierr14320
Messages postés
3
Date d'inscription
vendredi 26 octobre 2018
Statut
Membre
Dernière intervention
29 juin 2019
- 29 juin 2019 à 19:27
Bonjour, j'ai besoin vraiment d'aide.
Voila mon probleme, j'ai crée un tablespace,sur lequel un utilisateur avec dba. J'ai cree mes tables avec cet utilisateurs, j'ai crée mes synonymes avec ce dernier,j'ai donner des privileges de consultations a d'autres utilisateurs qui sont crées dans le meme tablespaces,je me connecte avec un de ses utilisateurs pour faire un describe mais l'erreur ora-04043 est la.
J'ai trouvé des solutions sur le net qui ne semble pas marché dans mon cas.
J'ai meme essayé de creer mes tables en specifiant mon tablespaces derriere,j'ai meme fait des describe directes avec nom_user.nom_tables;

J'ai interroger meme le dictionnaire pour voir si mes tables sont valides mais elles sont valides.
Je suis sous oracle11G,avec sqlplus.
Et juste pour info,j'ai crée deux bases et c'est sur la seconde je travaille.
Svp besoin de votre aide.suis meme depassé avec ce soucis.merci de me repondre s'il vous plait...
Afficher la suite 

2 réponses

Messages postés
777
Date d'inscription
mercredi 5 juillet 2017
Statut
Membre
Dernière intervention
9 juillet 2019
16
0
Merci
bonjour,

regarde ceci, https://www.developpez.net/forums/d491032/bases-donnees/oracle/debuter/ora-04043-objet-inexistant/
ps : je ne connais pas Oracle mais ne veux pas te laisser sans réponse :)

A+
Xavierr14320
Messages postés
3
Date d'inscription
vendredi 26 octobre 2018
Statut
Membre
Dernière intervention
29 juin 2019
-
Merci beaucoup.c'est admirable. Et j'avais vu cette resolution chez moi toujours sa donne pas.il dit toujours object inexistant. Malgré je met le nom_shema.ma_table
Enfaite j'ai tout retourner sur le net. Je vais effacer ma base et reprendre voir.merci HDU
Commenter la réponse de HDU
Messages postés
3
Date d'inscription
vendredi 26 octobre 2018
Statut
Membre
Dernière intervention
29 juin 2019
0
Merci
Ok j'ai commencer a refaire sur une autre base de données et sa semble marcher.
Pour ceux qui tombe sur le meme probleme que le mien:
J'ai une table=table1,
deux user user=user1 et user2,
Un synonym=synonym1
un role de nom role1.
Je donne dba a user1;
Je crée table1 avec user1, je fais mon role
role1 avec user1, je donne droit de consultation sur table1 a role1,ensuite j'attribu role1 a user1.
Je cree ma synonyme de nom synonym1 pour user1.table1 puis que c'est avec user1 j'ai cree ma table1
Je me connecte avec user2 et je fais :
Describe synonym1;

Nb: de fois comme dans mon cas,si j'etais sur deux fenetres sqlplus,si j'etais deja connecter avec user2 dans l'un et en meme temps dans l'autre je fais mon role et les droits, quant je reviens tester avec user2 sa me donne objet inexistant. Donc quant on se deconnecte puis se reconnecte avec user2 et on fais notre describe cela marche.
Commenter la réponse de Xavierr14320