Formule de calcul access [Résolu]

- - Dernière réponse :  MahieddineHAMMOUCHE - 26 juin 2019 à 15:12
Bonjour,
Jai besoin de votre aide SVP
J'ai la formule suivante sur Excel : =SI(ET(O3>=8,49;O3<=8,99);W3;SI(O3<=8,48;"0";(SI(O3>=9;M3))))
et j'aimerai bien la traduire en langage Access en IIF il me semble. Hélas je n'arrive pas
merci pour votre aide
Cordialement



Configuration: Windows / Edge 17.17134
Afficher la suite 

3 réponses

Messages postés
8717
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
17 octobre 2019
436
0
Merci
bonjour, qu'as-tu essayé, et quels résultats as-tu obtenu?
Commenter la réponse de yg_be
0
Merci
Bonjour
J'ai combiné trois IIf dans la formule de la manière suivante:
VraiFaux([O3]>=8,49 Et [O3]<=8,99;[W3];VraiFaux([O3]<=8,48;0;VraiFaux([O3]>=9;[M3];0)))
mais j'été obligé de rajouter à la fin le chiffre zéro; et je ne suis pas sur que ca sera la bonne solution!!!!!, mais elle fonctionne
Merci pour votre aide
Cordialement
yg_be
Messages postés
8717
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
17 octobre 2019
436 -
peux-tu alors marquer le sujet comme résolu, via la roue dentée à droite du titre?
-
Non pas encore, j'aimerai bien avoir votre aide pour retirer le zéro a la fin de la formule, car il est inexistant sur la formule Excel
Merci à vous
yg_be
Messages postés
8717
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
17 octobre 2019
436 > MahieddineHAMMOUCHE -
que penses-tu du dernier test dans Excel, à quoi sert-il?
SI(O3>=9;M3)
Commenter la réponse de MahieddineHAMMOUCHE
0
Merci
Merci à vous je viens de régler la problématique
Cordialement
Commenter la réponse de MahieddineHAMMOUCHE