Problème pour calculer le nombre de valeurs uniques d'une plage de données

Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
- - Dernière réponse : yg_be
Messages postés
8700
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
14 octobre 2019
- 14 juil. 2019 à 09:54
Bonjour,

https://cjoint.com/c/IFynwRVwd30

Comment calculer le nombre de valeurs uniques d'une plage de données qui contient des cellules vides?

J'ai une formule qui fonctionne quand les cellules ne sont pas vides (exemple 1)

Mais elle ne fonctionne pas quand la colonne contient des cellules vides.

Par avance merci.

Cordialement,
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
11192
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
13 octobre 2019
1451
1
Merci
Bonjour

Essaie cette formule matricielle à la place de la tienne :
=SOMME(SI(M5:M72<>"";1/NB.SI(M5:M72;M5:M72)))

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 62632 internautes nous ont dit merci ce mois-ci

badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
-
Merci!
yg_be
Messages postés
8700
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
14 octobre 2019
433 > badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
-
peux-tu alors marquer le sujet comme résolu, via la roue dentée à droite du titre?
Commenter la réponse de via55