Comptage selon 2 critères [Résolu]

Messages postés
396
Date d'inscription
samedi 26 août 2006
Statut
Membre
Dernière intervention
24 juin 2019
- - Dernière réponse : nlbmoi
Messages postés
396
Date d'inscription
samedi 26 août 2006
Statut
Membre
Dernière intervention
24 juin 2019
- 24 juin 2019 à 19:22
Bonjour

Je cherche à compter le nombre de cellules où 2 critères sont vérifiés : j'ai essayé avec la fonction NB.SI.ENS mais elle ne me donne pas le nombre attendu (j'ai fait au préalable avec chacun des critères ce qui me rend le bon nombre mais quand je mets les 2 critères le comptage n'est pas bon).
J'ai également testé la fonction sommeprod mais j'ai un problème de valeur.

Dans le fichier, onglet bilan_essai, je souhaite dénombrer (colonne C) le nombre de club qui réussissent les critères (le calcul pour les critères est dans l'onget controle - pour savoir s'il y a réussite, dans l'onglet controle je fais le test dans la ligne 14)

Merci pour l'aide

Le fichier exemple : https://www.cjoint.com/c/IFyeI5iMrF8

Configuration: Windows / Firefox 67.0
Afficher la suite 

1 réponse

Messages postés
2485
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
11 octobre 2019
279
0
Merci
Que ce soit nb.si.ens(), ou sommeprod(), ces formules ne fonctionne que sur des plages identiques (qui ont le meme nombre de cellule)
Et toi ? Tu mets des celulles fusionnées, qui ne comptent que pour une cellule !!!!
pour cela tu dois avoir 4 fois prenat, 4 fois région, etc...
Sommeprod() ne fonctionne pas sur des cellules vides (ex G14, E14,....), il te reste nb.si.ens() qui fonctionnera dans ce cas précis:
=NB.SI.ENS(Controle!$E$14:$T$14;VRAI;Controle!$E$40:$T$40;$A3)


Crdlmt
nlbmoi
Messages postés
396
Date d'inscription
samedi 26 août 2006
Statut
Membre
Dernière intervention
24 juin 2019
17 -
Ah ok, merci
Commenter la réponse de DjiDji59430