Erreur dans une formule…

Signaler
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
-
 Utilisateur anonyme -
Bonsoir à tous ;)

Pour rechercher toutes les valeurs qui se terminent par "an" et "and", j’ai essayé la formule suivante dans Excel :

=SI(OU(DROITE(C3;2)="an";DROITE(C3;3)="and");text_si_vrai;test_si_faux)

et il ya un problème : #NOM? s’affiche dans la cellule concernée.

Il y a donc une erreur quelque part.

Où se trouve-t-elle ? Quelqu’un aurait une idée ?

Merci



Configuration: Windows Seven sur PC et Mac osX 10.4.10 Ipad 2
Camino

10 réponses


Bonsoir,
Peut-être comme ceci :

=SI(OU(DROITE(C3;2)="an";DROITE(C3;)="and");"text_si_vrai";"test_si_faux")

La formule ne tient pas en une seule ligne du forum...
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Merci ;)

Guillemets sur point virgule entre vrai et test ?

Non, ça ne marche pas non plus.
Utilisateur anonyme
Les guillemets entourent "text_si_vrai"
et "test_si_faux" et non pas le point virgule. Sur mon Excel ça marche, si j'ai bien compris la question...
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Merci ;)

Mais ça revient au même, non ?
Utilisateur anonyme
Pas vraiment. Quel résultat cherchez vous à obtenir au juste ?
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Les mots qui se terminent par "an" et "and"

J’ai un autre problème
quand je saisi la formule ds la cellule apparaît non plus #NOM? mais la fin de la formule !

"text_si_faux")
Utilisateur anonyme
J'ai pris votre formule initiale, j'y ai juste ajouté les guillemets comme dit plus haut.
Si on écrit an en c3 on obtient text_si_vrai
si on écrit and en c3 on obtient text_si_vrai
si on écrit tout autre chose en c3 on obtient test_si_faux

Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
ptéranodon
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Voici deux captures d’écran je ne comprends rien…

Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Et
JvDo
Messages postés
1938
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
16 août 2019
781
Bonsoir à tous,

regarde un peu à quelle cellule ta formule fait référence !!!!

cdlt
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Exact ! Merci ;)

Pourtant, après avoir modifié C par D, jai toujours le même problème… :(


Utilisateur anonyme
Bonjour,
Envoyez le fichier par Cjoint svp.
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
Merci ;)

https://www.cjoint.com/c/IFvixWMfVxF

https://wetransfer.com/downloads/61c5a1aedc319962ab87d9ec628ac36620190621083920/74937c5601d982568b5c06ea75a2596620190621083920/1c6497


https://www.cjoint.com/c/IFviUxiRK0F
Utilisateur anonyme
Le fichier n'est plus ou pas disponible...
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
J’en ai mis d’autres avec Weransfer ;)
Utilisateur anonyme
La formule fonctionne sur mon Excel, voir ici :
https://cjoint.com/c/IFvjluTiMiI
Messages postés
316
Date d'inscription
dimanche 2 septembre 2007
Statut
Membre
Dernière intervention
6 mars 2020
2
J’ai trouvé l’explication !

Avec mes autres formules le résultat s’ affichait soit avec "vrai" soit avec "faux"
Avec cette autre formule il s’affiche d’une autre manière :

"texte_si_vrai" pour "VRAI"
ou
"texte_si_faux"pour "FAUX"

Bêtement, je pensais donc qu’il y avait une erreur dans la formule

Un grand merci en tous cas pour tes solutions ;)
Utilisateur anonyme
Vous avez trouvé... Bravo...