SI case = texte, plage =

Messages postés
2
Date d'inscription
mercredi 12 juin 2019
Statut
Membre
Dernière intervention
12 juin 2019
- - Dernière réponse : Exxes21
Messages postés
2
Date d'inscription
mercredi 12 juin 2019
Statut
Membre
Dernière intervention
12 juin 2019
- 12 juin 2019 à 18:57
Bonjour,

Je tente avec excel d'obtenir la somme d'une plage différente selon le texte d'une case.

Voici donc ce que j'ai fais :

=SI(H44=Mois;"'Liste de Prix'!M58:M90;E44;'Liste de Prix'!N58:N90";SI(H44=Semaine;"'Liste de Prix'!M58:M90;E44;'Liste de Prix'!O58:O90";SI(H44=Jour;"'Liste de Prix'!M58:M90;E44;'Liste de Prix'!P58:P90";)))

La case H44 représente soit Mois, semaine ou jour. La plage de prix dépend selon ce texte.

Le prix choisie dans la plage dépend du # de modèle.

Ce genre de manip fonctionne (sans la condition du texte d'une seconde case)
=SOMME.SI('Liste de Prix'!D:D;C30;'Liste de Prix'!E:E)

J'en ai 3 différentes pour le même C30 (Le E:E change mais pas le DD)

Moi je désire ajouter un SI case X = Mois (la plage SOMME se change en conséquence.)

Je ne sais pas si je suis réellement clair.

Merci beaucoup !
Afficher la suite 

2 réponses

Meilleure réponse
1
Merci
Bonjour,

D'après tes explications et faute de fichier pour tester, je te propose d'essayer :
=SI(H44="Mois";SOMME.SI('Liste de Prix'!M58:M90;E44;'Liste de Prix'!N58:N90);SI(H44="Semaine";SOMME.SI('Liste de Prix'!M58:M90;E44;'Liste de Prix'!O58:O90);SI(H44="Jour";SOMME.SI('Liste de Prix'!M58:M90;E44;'Liste de Prix'!P58:P90))))


Cordialement.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 65020 internautes nous ont dit merci ce mois-ci

Exxes21
Messages postés
2
Date d'inscription
mercredi 12 juin 2019
Statut
Membre
Dernière intervention
12 juin 2019
-
Merci beaucoup Gyrus, c'est exactement ce que je recherchais ! Réponse très rapide ! Je vois que ma syntaxe n'était pas au point.
Commenter la réponse de gyrus
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4841
1
Merci
Bon jour
pas trop compris, on essaie pour le principe

=SOMME.SI('Liste de Prix'!D:D;C30;SI('Liste de Prix'!C30="texte1";E:E;SI('Liste de prix'!C30="texte 2";F:F;G:G)))

ou alors:
nommez chaque champ E,F,G avec chaque nom de C30
la formule devient:
=SOMME.SI('Liste de Prix'!D:D;C30;INDIRECT('Liste de Prix'!C30))

crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 65020 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Vaucluse