Calcul Citères par mois

- - Dernière réponse : Vaucluse
Messages postés
24579
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2019
- 12 juin 2019 à 11:36
Bonjour,

Petit casse tête que je n'arrive pas à résoudre.
Sur mon tableau j'ai:

Colonne A: des dates (15/01/2019; 25/01/2019; 12/02/2019; 14/03/2019....)
Colonne B: des noms (Roger, Denis, Alexandre, Sylvain...)

J'arrive à calculer combien de dates correspondent à Janvier, février, Mars... Et les reporter sur un récap mensuel.

Mais je n'arrive pas à calculer combien de fois Roger apparait en janvier, Alexandre en mars etc...

Est ce que quelqu'un possède la solution.

Merci par avance et bonne journée


Configuration: Windows / Firefox 62.0
Afficher la suite 

2 réponses

Messages postés
1107
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
15 octobre 2019
134
0
Merci
Bonjour

La formule NBSI devrait faire le boulot.
Crdlt
Commenter la réponse de JCB40
Messages postés
24579
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2019
4826
0
Merci
Bonjour
soit un TCD soit, à adapter
  • date de A2 à A100
  • noms de B2 à B100
  • nom cherché en C2:C10
  • mois de janvier à décembre en D1:O1
  • en D2, la formule à tirer sur le tableau:

=SOMMEPROD((MOIS($A$2:$A$100)=COLONNE(A$1))*($B$2:$B$100=$C2))
respectez bien les $ aux bons endroits pour tirer la formule
crdlmnt


Commenter la réponse de Vaucluse