Faire varier les valeurs de cellules en fonction de deux critères

Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
- - Dernière réponse :  jelobou - 12 juin 2019 à 19:31
Bonjour,

ci joint le fichier sur lequel s'appuie ma question. https://www.cjoint.com/c/IFhlpuNLbK2.

Que dois-je inscrire comme formule dans "Q9-Q10-Q11" afin le contenu des cellules varient en fonction des deux critères inscrits dans les cellules prévues pour cela?

En bref, je voudrais pouvoir faire varier le résultat du nombre d'achats au marché, en fonction de ma selection au niveau des deux critères sélectionnés.


Par avance merci,
Cordialement,
Afficher la suite 

8 réponses

Meilleure réponse
1
Merci
Bonjour,

Proposition avec formule du type :
=SOMMEPROD(($D$6:$D$43=$L$5)*($E$6:$E$43=$L$2)*($G$6:$G$43=$P$3))

https://www.cjoint.com/c/IFhlPlBsPiQ

Cordialement.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64595 internautes nous ont dit merci ce mois-ci

Commenter la réponse de gyrus
Messages postés
27000
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
20 octobre 2019
5570
1
Merci
Bonjour,

Ou
=NB.SI.ENS(G6:G43;"MARCHE";E6:E43;L6;D6:D43;L9) 

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64595 internautes nous ont dit merci ce mois-ci

Commenter la réponse de jee pee
1
Merci
Bonjour,
l'utilisation du TDC (tableau croisé dynamique ) me parait tout à fait adaptée à votre problème.
Voir ma proposition ici :
https://cjoint.com/c/IFmrufkvoGT

Cordialement

J-Louis

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64595 internautes nous ont dit merci ce mois-ci

Commenter la réponse de jelobou
1
Merci
Avec le bon fichier c'est mieux

https://cjoint.com/data/IFmrCHsM5NT_Test.xlsx

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64595 internautes nous ont dit merci ce mois-ci

Commenter la réponse de jelobou
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
0
Merci
J'ai trouvé merci.

"Filtres" d'un TCD...

Merci!
Commenter la réponse de badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
0
Merci
Merci pour vos réponses.

J'ai essayé les deux. Les deux fonctionnent mais subsiste un problème.

Comment afficher le résultat, si aucun des critères de la liste déroulante n'est sélectionné? Ou seulement 1?

J'avais volontairement laissé la possibilité de laisser la cellule vide, dans le choix des critères avec la liste déroulante pour signifier"l'ensemble des variantes du critère" (= H + F par exemple, pas simplement l'un ou l'autre).

Merci d'avance!
jee pee
Messages postés
27000
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
20 octobre 2019
5570 -
Le NB.SI n'est pas très souple. Dans la valeur testée on ne peut pas mettre une formule ou fonction.

Pour H+F il faudrait faire :
=SI(ESTVIDE(L6);NB.SI.ENS(G6:G43;P7;D6:D43;L9);NB.SI.ENS(G6:G43;P7;E6:E43;L6;D6:D43;L9))


Pour l'ensemble des nationalités, il faudrait à nouveau multiplier la formule ci-dessus par 2 ;-/

Ou alors dans tes listes déroulantes, tu remplaces blanc par *, qui signifie TOUT

Et la formule de départ fonctionne.
=NB.SI.ENS(G6:G43;P7;E6:E43;L6;D6:D43;L9)
badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
-
Parfait!

La solution avec l'étoile! J'ignorais que"*"signifiait tout.

Merci beaucoup
jee pee
Messages postés
27000
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
20 octobre 2019
5570 > badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
-
Tout pour la valeur testée dans NB.SI

C'est ce qui s'appelle un caractère joker. "T*" tout ce qui commence par T, "*A", tout ce qui se termine par A, "*AS*" tout ce qui contient AS, et au final "*", tout.
badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
-
Top!
Commenter la réponse de badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
0
Merci
Par curiosité, pourquoi cela ne fonctionne pas avec SOMMEPROD() ?

"*" les caractères joker ne se sont compris qu'avec NB.SI.ENS()?
Vaucluse
Messages postés
24613
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 octobre 2019
4839 -
les caractères * ne sont compris que par les codes qui utilisent le point virgule comme séparateur des items qui la composent
SOMMEPROD utilise une égalité ou une comparaison numérique et ne peut donc pas utiliser une référence partielle
Et de même les * ne fonctionnent pas avec des valeurs num
Toutefois, il est possible dans certain cas de recherche de texte, de combiner SOMMEPROD et NB.SI
crdlmnt
Commenter la réponse de badarledur
Messages postés
46
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
13 juillet 2019
0
Merci
Merci pour cette réponse
Commenter la réponse de badarledur