(not found Newtonsoft.Json.dll) application problem

Messages postés
1
Date d'inscription
mardi 4 juin 2019
Statut
Membre
Dernière intervention
4 juin 2019
- - Dernière réponse : [Dal]
Messages postés
5249
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
15 octobre 2019
- 4 juin 2019 à 10:32
bonjour je suis sure votre site depuis pas mal de temps deja pour avoire une reponse a se que je cherche tjr donc un gros merci a vous
est si je posse ma premier question aujourd'hui cest pour avoir une reponse a un pti truc qui menpeche a beaucoud de chose
not found Newtonsoft.Json.dll
cest ce que m'affiche quelque aplication qui on besoin de dll pour souvrir j'ai fais quelque recherche pour avoire une solution gratuit mai rien i fait aidez a ouvrire mon aplication a debloquez dll pour ouvrir mais appli
si non merci a vous pour se forum genial
Afficher la suite 

1 réponse

Messages postés
5249
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
15 octobre 2019
806
0
Merci
Salut DLL_0073,

1.

Le programme que tu essayes de lancer est mal installé ou des fichiers nécessaires à son installation ou à son fonctionnement sont manquants ou ont été effacés. Le mieux est de désinstaller ce programme, télécharger le programme d'installation complet auprès du fournisseur officiel de ce programme et de réinstaller.

2.

Si tu veux essayer de réparer manuellement l'installation, ce fichier .dll devrait venir du projet Newtonsoft.Json et tu peux télécharger un fichier .zip sur leur dépôt GitHub officiel Json120r2.zip contenant différentes versions de Newtonsoft.Json.dll là :

https://github.com/JamesNK/Newtonsoft.Json/releases

Le fichier readme.txt indique ceci :

Json.NET has different libraries for the various .NET Framework versions.

-net45:
.NET 4.5+

-net40:
.NET 4.0

-net35:
.NET 3.5

-net20:
.NET 2.0, Unity

-portable-net45+win8+wpa81+wp8:
.NET 4.5, Windows Phone 8, Windows 8 Store

-portable-net40+win8+wpa81+wp8+sl5:
.NET 4.0, Windows Phone 8, Windows 8 Store, Silverlight 5, MonoTouch, MonoDroid

-netstandard1.0:
.NET Standard 1.0

-netstandard1.3:
.NET Standard 1.3

-netstandard2.0:
.NET Standard 2.0

Il te faudra déterminer quel framework .NET est utilisé par ton application pour installer la bonne .dll (cela devrait être indiqué par la documentation du programme que tu essayes de lancer).

Chaque répertoire contient 3 fichiers : Newtonsoft.Json.dll, Newtonsoft.Json.pdb, Newtonsoft.Json.xml. Une fois que tu as déterminé la bonne version à utiliser, il faut copier ces fichiers dans ton répertoire c:\windows ou dans le répertoire d'installation du programme où se trouve l'exécutable que tu tentes de lancer.

Le mieux, si tu ne t'y connais pas trop, est de faire comme indiqué en 1.

Dal
Commenter la réponse de [Dal]