Formule index equiv [Résolu]

Messages postés
1134
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2019
- - Dernière réponse : JCB40
Messages postés
1134
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2019
- 4 juin 2019 à 18:31
Bonjour,
J'ai une erreur que je ne trouve pas sur cette formule,
https://www.cjoint.com/c/IFdmjiubZLk
Ou se trouve le problème?
Cordialement


Configuration: Windows / Firefox 67.0
Afficher la suite 

5 réponses

Meilleure réponse
Messages postés
1705
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
18 octobre 2019
426
1
Merci
Bonsoir
une proposition
la difficulté est de traiter le exæquo car la fonction EQUIV done la 1ère valeur trouvée
reste à traiter les erreurs

peut être plus simple de mettre le classement trié en colonne
exemple

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64460 internautes nous ont dit merci ce mois-ci

JCB40
Messages postés
1134
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2019
139 -
Bonjour
Merci pour ton aide.
Je te joins le fichier modifié avec nouvelles explications
https://www.cjoint.com/c/IFdpKfUMlek
Cordialement
yclik
Messages postés
1705
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
18 octobre 2019
426 -
pas plus de solution
yclik
Messages postés
1705
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
18 octobre 2019
426 -
Autre proposition


A recopier à droite et en bas
en c2
=SI($A2=C$1;LIGNE();"")


en G2
=INDEX($B$2:$B$10;EQUIV(PETITE.VALEUR(C$2:C$10;LIGNE()-1);C$2:C$10);0)


en K2 avec traitement erreur
=SI(ESTERREUR(PETITE.VALEUR(C$2:C$10;LIGNE()-1));"";INDEX($B$2:$B$10;EQUIV(PETITE.VALEUR(C$2:C$10;LIGNE()-1);C$2:C$10);0))		
Commenter la réponse de yclik
Messages postés
15936
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 octobre 2019
2813
1
Merci
Bonjour,

https://mon-partage.fr/f/bnU3gRbR/

on devrait pouvoir le faire avec une seule formule matricielle pour chaque cas(1,2,3) mais pour l'instant je sèche...

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 64460 internautes nous ont dit merci ce mois-ci

Commenter la réponse de michel_m
Messages postés
1134
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2019
139
0
Merci
Après réflexion je ne sais même pas si j'utilise la bonne formule
Commenter la réponse de JCB40
Messages postés
1134
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2019
139
0
Merci
Re bonjour
Quelle est la bonne formule que je dois utiliser dans mon tableau pour avoir le résultat souhaité?
Cordialement
Commenter la réponse de JCB40
Messages postés
1134
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
20 octobre 2019
139
0
Merci
Bonjour yclick et michel

Merci pour votre aide.
J'étais loin avec ma formule
Désolé yclick j'ai adopté la solution de michel qui est plus simple.
Mais je garde ta solution en stock.
Cordialement
Bonne soirée
Commenter la réponse de JCB40