Inverser les résultats du classement obtenu avec nb.si.ens

-
Bonjour,

J'ai un soucis avec un fichier pour l'enregistrement des résultats d'une compétition sportive.

Je cherche à obtenir un classement par catégorie mais où le 1er rang correspond au nombre de points le plus bas.
En A : numéro de dossard
En B : catégorie
En C : le nombre de points obtenus
En D : le classement général (obtenu via la fonction RANG dans l'ordre décroissant du nombre de points)
En E : le classement par catégorie.
Pour l'instant en E, j'utilise la fonction =nb.si.ens(B2:B26;B2;C2:C26;">"&C2)+1. J'obtiens bien le classement par catégorie mais dans l'ordre croissant du nombre de points.

Auriez-vous une solution ?

Merci


Configuration: Windows / Chrome 49.0.2623.112
Afficher la suite 

2 réponses

Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4843
0
Merci
Bonjour
on ne voit pas très bien ce que vous pouvez obtenir comme classement avec NB.SI.ENS?
pouvez vous déposer un modèle en ajoutant quelques explications et en bidonnant si besoin les infos confidentielles ici:
http://mon-paratge.fr
et revenir coller le lien créé sur le site
à vous lire
crdlmnt
Bonjour,

Voici le fichier : https://mon-partage.fr/f/xr4DdvX2/

Merci
Commenter la réponse de Vaucluse
Messages postés
2002
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
21 octobre 2019
230
0
Merci
Bonjour,

Exemple en K2 et à tirer vers le bas
=SI((NB.SI.ENS($B$2:$B$26;$B2;$H$2:$H$26;"<"&$H2))=0;1;(NB.SI.ENS($B$2:$B$26;$B2;$H$2:$H$26;"<"&$H2)+1))

Avec le fichier
https://mon-partage.fr/f/FPeI5in4/

Cdlt
Commenter la réponse de Frenchie83