Remplissage automatique de champs en fonction du contenu de la col. précédente [Résolu]

-
Bonjour,
Alors je souhaite d'abord m'excuser de ce titre très vague, mais je vous explique ce que je souhaite faire :
Pour faire simple, je possède une liste "d'objet" que possède eux même plusieurs "pièces". Je souhaite donc obtenir une formule qui me permettrait de faire comme suit:

Colonne iD_objet | Colonne ID_Piece de l'Objet
Objet1 | Objet1a
Objet1 | Objet1b
Objet1 |Objet1c
Objet2 | Objet2a
etc

C'est à dire que je souhaite qu'excel reconnaisse par exemple ici que les 3 premières lignes concerne un même objet et associe donc dans la deuxième colonne les lettre de a à z en fonction du nombre d'occurence de Objetx. Puis repartir à "a" une fois un second objet entamé

En espérant avoir été un peu clair...
Bonne journée
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
589
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
26 juin 2019
46
2
Merci
bonjour,

est ce que cela suffit?

=SI(A2=A1;A2&CAR(64+NB.SI($A$1:A2;A2));A2&"A")

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 65168 internautes nous ont dit merci ce mois-ci

Merci beaucoup !
Cela semble fonctionner ;)
fabien25000
Messages postés
589
Date d'inscription
mercredi 5 octobre 2016
Statut
Membre
Dernière intervention
26 juin 2019
46 -
on pourrait peaufiner en testant avec =SI(NB.SI($A$1:A2;A2)=1;A2&"A";A2&CAR(64+NB.SI($A$1:A2;A2)))
de cette façon si objet1 reviens 20 lignes plus bas tu ne repars pas depuis "A"
par contre à savoir, c'est que une fois arrivé à Z, tu vas tomber sur des symboles (6) et ensuite repartir sur l'alphabet en minuscule hors excel ne respecte pas la casse dans les formules de comparaison (en VBA si mais pas avec les formules "basiques")
Commenter la réponse de fabien25000