Connexion SSH permission denied [Résolu]

- - Dernière réponse :  laura - 20 mai 2019 à 15:25
Bonjour,

j'ai creé 2 machines virtuelles ( Ubuntu ) , ils sont connecté dans le meme réseau ( le Ping marche entre eux ) . j'ai configuré une comme serveur SSH et l'autre comme client .
ssh laura@XXX XXX XXX XXX -p 3008
j'ai essayé de me connecter avec la machine cliente sur mon serveur en tapant la commande :
ssh laura@XXX XXX XXX XXX -p 3008 ( j'ai changé le port par defaut )
un message s'affiche pour me demander de taper un mot de passe : j'ai saisi le mot de passe défini pour ma session Ubuntu et le meme que pour Root ( c'est bien ça ? )

il m'affiche : permission denied , try again.
je comprend pas c'est quoi le probleme

Merci



Configuration: Windows / Chrome 70.0.3538.102
Afficher la suite 

1 réponse

Messages postés
10
Date d'inscription
samedi 13 décembre 2014
Statut
Membre
Dernière intervention
20 mai 2019
0
Merci
Salut !
Tu as modifié le port par défaut dans ton /etc/ssh/sshd.conf pour utiliser le 3008 ?
oui c'est ça . mais j 'ai essayé aussi dans l autre sens ( j'ai échanger les roles entre le client / serveur ) ,j'ai gardé le port par default pour la deuxieme machine (22) et ça ne marche pasn aussi.

j'ai modifié le fichier /etc/hosts.allow , j'ai ajouter cette ligne : sshd : ALL et j'ai redemarré le service . mais ça marche toujours pas

j'ai véréfier dans les logs ( /var/logs/auth.log) , c'est ecrit : failed password for invalid user from XXXXXXXXXXXX port XXXX ssh2

alors que mon user est valide et aussi le mot de passe

à noter que si je connecte sur mon serveur lui meme ( en localhost ) , cela fonctionne
Acidtrader
Messages postés
10
Date d'inscription
samedi 13 décembre 2014
Statut
Membre
Dernière intervention
20 mai 2019
-
Si tu es sûre de ta saisie (Qwerty ....) as-tu également modifié autre chose dans ton fichier de conf comme la méthode d'authentification ?

Il n'y a pas d'utilisateur "root" sous Ubuntu

Fait un
passwd laura
sur chaque machine
Puis retente ton
ssh laura@xxxxxxxxxx
de A vers B
> Acidtrader
Messages postés
10
Date d'inscription
samedi 13 décembre 2014
Statut
Membre
Dernière intervention
20 mai 2019
-
non j'ai pas modifié la methode d'authentification . pour le user avec lequel j'essaye de s'authentifier , je l'ai créer avec la commande: sudo adduser NomUtilisateur , et j'ai défénis un mot de passe
Acidtrader
Messages postés
10
Date d'inscription
samedi 13 décembre 2014
Statut
Membre
Dernière intervention
20 mai 2019
-
Truc bête mais tu as fait un
service sshd restart
après la modif de ton fichier de conf ?
> Acidtrader
Messages postés
10
Date d'inscription
samedi 13 décembre 2014
Statut
Membre
Dernière intervention
20 mai 2019
-
, c'est résolu hhh c'etait con de ma part . on fait j'ai créé l'utilisateur au niveau de la machine cliente au lieu de le creer sur la machine serveur .
Merci beaucoup
Commenter la réponse de Acidtrader