Menu

Formule [Résolu]

Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
- - Dernière réponse : Pacino51
Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
- 21 mai 2019 à 12:51
Bonjour,

je cherche une formule pour effectuer :

si je rentre un chiffre dans une cellule "exemple A1" cela va me chercher une valeur pour l'inscrire dans la "cellule exemple B1".

a savoir que le chiffre dans la cellule "exemple A1" va varier de 1 à 20 et que selon le chiffre la valeur rechercher (dans un tableau déjà rempli) sera différente.

exemple en gros - si "1" dans "A1" = "tel valeur de cellule" dans "B1"
- si "2" dans "A1 = "tel autre valeur d'autre cellule" dans "B1"

actuellement j'utilise une formule :
=SI(ESTNUM(CHERCHE("1";I7));Feuil1!G3)

mais je n'arrive pas a faire plusieurs variable

je recherche la même chose mais avec :

si "2" dans telle cellule rechercher "telle cellule", si "3" rechercher "tel cellule".....
Afficher la suite 

2 réponses

Messages postés
1972
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 juin 2019
373
0
Merci
Bonjour

un essai

Cordialement
Pacino51
Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
-
juste maintenant les valeurs sont sur un autre onglet (tableau feuille 1)
PapyLuc51
Messages postés
1972
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 juin 2019
373 > Pacino51
Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
-
Nouvel essai avec 2 solutions

Cordialement
Pacino51
Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
-
PapyLuc51
Messages postés
1972
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 juin 2019
373 -
Avec le tableau exemple c'est plus facile - Comme le disait Vaucluse (salutations) il faut mettre les $ aux bons endroits ou utiliser une zone nommée

https://www.cjoint.com/c/IEulG2YonJU

Cordialement
Pacino51
Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
-
merci parfait
Commenter la réponse de PapyLuc51
Messages postés
24087
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
4630
0
Merci
Bonjour
exemple à adapter
  • de y1 à Y20 la liste des codes d'entrées
  • de Z1 à Z20 la liste des valeurs correspondantes à afficher
  • en A2 une valeur de Y entrée au clavier
  • en B2 pour trouver la valeur correspondante:

=SI(A2="";"";RECHERCHEV(A2;$Y$1:$Z$20;2;0))
à tirer sur la hauteur utile en respectant les signes $ aux bons endroits
crdlmnt
Pacino51
Messages postés
6
Date d'inscription
lundi 20 mai 2019
Statut
Membre
Dernière intervention
21 mai 2019
-
étant novice je n'arrive pas a adapter a ma situation
Commenter la réponse de Vaucluse