Menu

Problème avec cellule vide [Résolu]

Messages postés
251
Date d'inscription
vendredi 8 avril 2005
Statut
Membre
Dernière intervention
20 mai 2019
-
Bonjour,
J'ai un tableau qui se rempli avec la fonction RECHERCHEV.
Toutefois, lorsqu'un élément (ici le PU ) manque, il inscrit "0"
Or, j'aurais souhaité qu'il laisse plutôt la case vierge.
Quelqu'un pourrait-il me dire comment procéder ?
Merci d'avance
IEtoQnNNn3Z_Modèle.xlsx


Configuration: Windows / Edge 17.17134



daniel22
Afficher la suite 

7 réponses

Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
260
0
Merci
Bonjour à tous,

S'il inscrit 0, c'est parce que ta formule commence par sierreur et se termine par 0)
tu remplaces le 0 par "", a condition que tu dans ta colonne ne fasses pas d'additions dans cette colonne.


Crdlmt
Commenter la réponse de DjiDji59430
Messages postés
251
Date d'inscription
vendredi 8 avril 2005
Statut
Membre
Dernière intervention
20 mai 2019
0
Merci
Merci pour ta réponse, mais si je remplace 0 par "" il m'indique alors #VALEUR!

DjiDji59430
Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
260 -
Bonjour,

Un fichier (test) mis sur https://www.cjoint.com/ permettrait de répondre plus précisément à ta question

Crdmt
Commenter la réponse de daniel22
Messages postés
49110
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 juin 2019
10039
0
Merci
La case ne sera jamais vierge, puisqu'elle contient une formule.
Et puisque c'est une formule de recherche, elle affichera toujours un résultat.

Et tu as mal utilisé Cjoint.com : Ton lien est vide !
Commenter la réponse de Raymond PENTIER
Messages postés
1972
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 juin 2019
373
0
Merci
Bonjour

à tenter demander à excel de ne rien inscrire si la cellule PU n'indique rein

=SI(cell PU<>"";formule RECHERCHEV;"")

Cordialement
Commenter la réponse de PapyLuc51
Messages postés
251
Date d'inscription
vendredi 8 avril 2005
Statut
Membre
Dernière intervention
20 mai 2019
0
Merci
Merci pour vos réponses.
Désolé pour le lien vide…..le voici https://www.cjoint.com/c/IEugg1lXwUN

Pour PapyLuc51, ça ne fonctionne pas.

Merci pour votre aide.
PapyLuc51
Messages postés
1972
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
17 juin 2019
373 -
Re:
C'était une piste sans voir ton tableau. Tu peux soit suivre les indications de Michel_m (salutations) ; soit ruser avec les formules déjà inscrites :

Rectifier D2
=SI(RECHERCHEV($F2;$J$1:$L$10;3;0)>0;RECHERCHEV($F2;$J$1:$L$10;3;0);"")

Rectifier aussi E2
=SI(D2="";"";B2*D2)

Cordialement
daniel22
Messages postés
251
Date d'inscription
vendredi 8 avril 2005
Statut
Membre
Dernière intervention
20 mai 2019
-
Impéccable, cela fonctionne.

Merci PapyLuc51
Commenter la réponse de daniel22
Messages postés
15868
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
18 juin 2019
2746
0
Merci
Bonjour,

si tu veux absolument que rien n’apparaisse si le prix n'est pas fixé
Commenter la réponse de michel_m
Messages postés
2399
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 juin 2019
260
0
Merci
Bonjour à tous,

Un dernier effort !
https://www.cjoint.com/c/IEuhG6h2vuw

Crdlmt
Commenter la réponse de DjiDji59430