Menu

Formules Excel [Résolu]

Messages postés
11
Date d'inscription
vendredi 22 mars 2019
Statut
Membre
Dernière intervention
19 mai 2019
- - Dernière réponse : alexnikky
Messages postés
11
Date d'inscription
vendredi 22 mars 2019
Statut
Membre
Dernière intervention
19 mai 2019
- 18 mai 2019 à 13:34
Bonsoir à vous utilisateurs d'Excel,

Est-ce qu'une âme charitable pourrait m'aider svp :
J'ai une liste de chiffres dans une colonne (positive et négative), et je souhaiterai afficher dans une nouvelle colonne avec ces chiffres avec comme :
Exemple pour chiffre positif : 4 ==> Dans nouvelle colonne : J'aimerai qu'il y ai écrit "4jours de retard"
Exemple pour chiffre négatif : - 5 ==> Dans nouvelle colonne : J'aimerai qu'il y ai écrit "5 jours restants"

Je sais c'est inversé mais c'est bien dans ce sens là que j'aimerai les faire apparaitre

Merci à celles et ceux qui prendont le temps de m'aider

Bonne soirée :)
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
1933
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 mai 2019
476
2
Merci
Bonsoir,

Et quoi faire si c'est 0

nombre en A1
en B1 =SI(A1<0;ABS(A1)&" jour(s) restant(s)";SI(A1>0;A1&" jour(s) de retard";mettre la valeur pour le 0 si c'est le cas sinon "" pour que la cellule reste vide))

Cordialement

Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39099 internautes nous ont dit merci ce mois-ci

Commenter la réponse de PapyLuc51
Messages postés
1933
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 mai 2019
476
0
Merci
Bonjour alexnikky

Et pour faire le distinguo du singulier et du pluriel

=SI(A1<0;ABS(A1)&" "&SI(ABS(A1)>1;"jours restants";"jour restant");SI(A1>0;A1&" "&SI(A1>1;"jours de retard";"jour de retard");mettre la valeur pour le 0 si c'est le cas sinon "" pour que la cellule reste vide))

Si c'est toi qui a cliqué sur merci c'est que ma première réponse a résolu ta question, statut à confirmer par un clic sur la roue dentée à droite du titre.

Cordialement
alexnikky
Messages postés
11
Date d'inscription
vendredi 22 mars 2019
Statut
Membre
Dernière intervention
19 mai 2019
-
Merci au top ça fonctionne à merveille :)
Commenter la réponse de PapyLuc51