Menu

Mettre à jour OpenSSH

- - Dernière réponse : mamiemando
Messages postés
28841
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
14 juin 2019
- 19 mai 2019 à 16:46
Bonjour,

j'ai la version 7.6 d'OpenSSH , sur Wiki c'est écrit que la derniere version est la V8.0 ( Avril 2019). j'ai essayé de mettre le paquet à jour ( sudo apt-get install openssh-server ) mais il m'affiche " 0 mis à jour"

comment faire pour installer la derniere version svp ?

Merci

Configuration: Windows / Chrome 70.0.3538.102
Afficher la suite 

1 réponse

Messages postés
28841
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
14 juin 2019
6575
0
Merci
Bonjour,

La version d'
openssh
que tu récupères via
apt-get
dépend de la version d'ubuntu/debian que tu as défini dans
/etc/apt/sources.list
(e.g. jessie, buster etc. sous debian ; xenial, bionic, cosmic etc. sous ubuntu).

Tu peux voir sur ces deux pages quelles versions sont mises à disposition en fonction de la release d'ubuntu/de debian que tu utilises.
https://packages.debian.org/search?searchon=names&keywords=openssh-server
https://packages.ubuntu.com/search?keywords=openssh-server

Actuellement, les dernières versions mises à disposition dans apt sont (pour ces deux distributions)
1:7.9p1-10


Vu la version que tu sembles indiquer, je dirais que tu utilises une ubuntu bionic, donc si tu souhaites utiliser une version plus récente d'
openssh
il faut soit attendre quelle soit déposée dans les dépôts bionic, soit migrer vers une version d'ubuntu plus récente. Si tu décides de le faire, attention à bien sauver tes documents précieux sur un autre support, on ne sait jamais.

Si le problème de fond, c'est juste sécuriser ssh, regarde du côté de
fail2ban
, et utilise des clés ssh pour désactiver les authentifications par mot de passe.

Bonne chance
Commenter la réponse de mamiemando