Menu

Formule soustraire SI

Messages postés
460
Date d'inscription
samedi 11 octobre 2008
Statut
Membre
Dernière intervention
12 mai 2019
- - Dernière réponse : Vaucluse
Messages postés
23973
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
- 12 mai 2019 à 15:14
Bonjour,
Je rencontre un petit problème pour une création de feuille de calcul. Je m’explique :
Je souhaite faire une feuille de calcul d’heures effectuer et d’heure supplémentaire. Tout c’est bien passer sauf que maintenant je voudrait soustraire 8h (8:00) au cumul de ma journée qui est en I6. J’ai utilisé pour cela la formule =-TEMPS(8;0;0) cela fonctionne bien : si je travaille 8h il affiche 0h sup et si je travaille 9h il affiche 1h sup, sauf que si je travaille pas comme les congés par exemple il m’indique : -8h (-8:00) ???? je voudrait qu’il m’indique 0 si les journées ne sont pas travaillées... j’ai donc essayé avec une formule SI I6=> mais cela ne fonctionne pas .... pouvez-vous m’aider ?
Merci à tous
Afficher la suite 

Votre réponse

2 réponses

Messages postés
5313
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
22 mai 2019
313
0
Merci
Bonjour Bombero-11

Mettre un testedans votre formule

=SI(cellule="";0;votre formule actuelle)



bombero-11
Messages postés
460
Date d'inscription
samedi 11 octobre 2008
Statut
Membre
Dernière intervention
12 mai 2019
36 -
Donc la formule serait : =SI(I6='''';8;-TEMPS(8;0;0)) ?
PHILOU10120
Messages postés
5313
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
22 mai 2019
313 -
=SI(I6='''';0;-TEMPS(8;0;0)) pourquoi 8 si c'est un congés = 0 ou CA
Vaucluse
Messages postés
23973
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
4595 -
Bonjour Philou
Quelque chose m'échappe, là (depuis le début) Si cette formule ne fait pas référence à I6 dans sa seconde partie, elle va avoir du mal à trouver la différence entre I6 et 8h, non
Si je dis que depuis le début, c'est que le message initial annonce la formule:
=-TEMPS(8;0;0) qui, sans le I6 renvoie une série de ###### (logique),
alors que, au final: =SI(I6<=8/24;0;I6-8/24)
fait bien simplement l'affaire, ou alors si on y tient:
=SI(I6<=TEMPS(8;0;0);0;I6-TEMPS(8;0;0))
crdlmnt
Commenter la réponse de PHILOU10120
Messages postés
23973
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
4595
0
Merci
Bonjour
écrivez simplement
=SI(I6<=8/24;0;I6-8/24)

crdlmnt


Commenter la réponse de Vaucluse