Menu

Probleme carte graphique radeon vega et linux mint 19 [Résolu]

Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
-
Bonjour,
Je viens d'installer LM19 sur mon laptop lenovo ideapad L340 et j'ai un message d'erreur comme quoi cinnamon fonctionne en mode rendu du logiciel et qu' il ne peut pas utiliser les capacités d' acceleration du processeur graphique , j'ai essayé de mettre les drivers amd pour ubuntu 18.04 mais cela na pas fonctionné,si quelqu'un a une idée ?
pour info apres plusieurs essai de différentes version de linux en live,seul solus a prit en compte ma GC sans problème


Firefox 66.0</cpu;AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx dualboot : WS 10-Linux Mint 19.1 Tessa Cinnamon
Afficher la suite 

Votre réponse

6 réponses

Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
0
Merci
Bonsoir , j'ai également un Pc Lenovo récent ( Lenovo Ideacentre 310S / 08asr ) avec carte graphique Radeon ... , ce Pc refuse pas mal de distributions . Celle qui a fonctionné jusqu'à aujourd'hui est Ubuntu 16.04.1 mais elle est maintenant obsolète , je crois . J'ai donc installé Fedora 29 qui marche très bien .
Mint 17, 18 ou 19 ne fonctionnent pas sur ce Pc , Solus Budgie non plus , Manjaro et Ubuntu 18 non plus + quelques autres ... Il faut faire des essais et trouver une distribution qui marche avec votre Pc .
Commenter la réponse de WalterP
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
0
Merci
Je comprends mais trouver une distribution de linux compatible,"facile",mis a jour assez régulièrement avec une communauté active et en français et qui en plus pourrait me plaire graphiquement ,ça devient un vrai casse tète et chronophage .
Je suis vraiment étonné c'est un problème plus lié a lenovo ou bien ça touche d'autre marque/config
WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
-
Oui , d'après ce que l'on m'a dit sur un forum Ubuntu c'est la carte graphique qui est en cause ... ou le processeur , je ne sais pas , je ne m'y connais pas assez .

En fait ma carte graphique est : AMD® Stoney , et le processeur : AMD® E2-9030 radeon r2, 4 compute cores 2c+2g × 2.

Mon Pc étant presque neuf il a bien fallu que je trouve une solution , j'ai donc essayé différentes distributions , ça ne prends pas tellement de temps si on les grave sur clé USB .
Sur Linux l'utilitaire pour graver une clé Usb est déjà installé . Sur Windows il faut peut-être passer par Unetbootin pour formater la clé Usb au préalable .

Donc , sur mon Pc , Ubuntu 16.04.1 fonctionne ainsi que Fedora 29 Workstation . En fait , Linux Mint Debian Edition 2 ( LMDE2 ) fonctionnait presque bien , sauf le défilement de la page qui avait quelques ratés . A essayer sur votre machine ...
Commenter la réponse de repie007
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
0
Merci
c'est sur que le gros avantage est de pouvoir utiliser en liveusb bien que je me retrouve des fois bloqué car l'interface reste en anglais ,le clavier en qwerty...
pour moi hormis ce message d'erreur et une carte wifi qui n’était pas reconnu LM19 fonctionne pas trop mal,solus budgie même problème de wifi que LM19 et même solution apporté mais le reste fonctionne bien,fedora écran noir malgré le check au demarrage qui disait ok.
je suis tenté d'installer solus pour voir sur un peu plus de temps mais j'ai déjà WS10+LM19,qui est la distrib que j'aimerais conserver . Je vais finir par regretter mon choix de pc du moins la config AMD qui semble être incompatible
WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
-
Oui , sur linux Mint il y a beaucoup d'applications pour le graphisme et la photo , ce qui est intéressant .
Pour le choix du Pc je regrette également , mais il aurait fallu connaître ce problème de carte graphique auparavant ..
J'ai également 2 anciens Pc Lenovo qui , eux , fonctionnent très bien avec Mint ou Ubuntu ! Mystère ...
Commenter la réponse de repie007
0
Merci
Bonjour,
Essaie de passer le paramètre
nomodeset
au démarrage
si c'est pas bon, essaie aussi le paramètre
radeon.dpm=0
.
Voir ici pour la manière de procéder :
https://doc.ubuntu-fr.org/kernel#parametres_du_noyau

Personnellement, j'ai placé AMD sur liste noire vu le peu de respect qu'ils ont pour les utilisateurs linux.
Non seulement ils refusent de coopérer avec la communauté linux, ils ont arrêté le support linux pour leurs cartes graphiques disant aux utilisateurs qu'ils n'ont qu'à utiliser le pilote libre (faut le faire !).
Intel eux, coopèrent et il n'y a pas de problèmes de ce genre...
WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
-
Ok , merci jns55 pour le tuyau ! Je prends note de la procédure ci-dessus !
repie007
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
-
merci pour l'info jns55 j'essaie de regarder ca cet aprem.
Apres pour AMD je suis de cul, dénigrer a ce point une part de +en+ importante d'utilisateur de linux ne me parait pas une bonne stratégie !!
repie007
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
-
dommage aucune des deux commandes n'ont resolu mon probleme merci quand meme
C'est vraiment une carte graphique chiante. De nombreux posts relatent des problèmes avec cette puce.
Sur ce forum
https://askubuntu.com/questions/1078568/unable-to-install-ubuntu-18-04-on-amd-ryzen-2500u-with-radeon-vega-8-gfx/1132308
un intervenant dit qu'il n'est parvenu à installer linux qu'après mise à jour du bios...
Attention, c'est une opération qui n'est pas sans risque.
D'autres comme :
In order to get the system even to boot i changed the grub line from
quiet splash
to
nosplash pci=noacpi rcu_nocbs=0-7 processor.max_cstate=1

sont à tester mais je vois mal comment supprimer quiet et remplacer splash par nosplash peut avoir une incidence (splash, c'est pour afficher le logo de démarrage et quiet c'est pour dire au système de ne pas afficher les messages de démarrage !) le reste de la ligne, peut_être faut essayer.
Commenter la réponse de jns55
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
0
Merci
chiant est le mot!!!sur quoi joue la fin de la ligne ? faudrait que je la place après quiet splash donc?
après sur solus le pilote utilisé est amdgpu qui est aussi présent sur LM19 mais il ne se lance pas au demarrage,le truc c'est que je ne sais pas du tout comment faire
Tu enlèves quiet et splash pour avoir les messages de démarrage et tu le colles à la place. Tu bootes et tu vois ce que ça donne. (c'est pas une modif définitive à ce stade)

D'après ce que j'ai compris AMD préconise l'emploi du pilote libre Radeon mais a édité un pilote complémentaire nommé amdgpu-pro. (j'aurais aimé qu'il y ait aussi des pilotes pour les cartes un peu plus anciennes car lorsque le pilote libre ne donne pas satisfaction on fait quoi ? AMD s'en fout complètement.)

Il faut télécharger ce pilote sur le site Ati . Regarde si tu n'as pas un gestionnaire de pilotes dans Mint et s'il ne te propose pas de l'installer.
https://linuxconfig.org/how-to-install-the-latest-amd-radeon-drivers-on-ubuntu-18-04-bionic-beaver-linux

(ce qui est bon pour Ubuntu est bon pour Mint)
repie007
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
-
J'ai essayé avec la ligne de commande mais c'est chiant le clavier est en qwerty sur le grub,bref apres un peu de lutte j'ai eu un ecran noir puis le son d'ouverture de session et c'est tout.
Le pilote que tu cite c'est pas le même qui est déjà installé sur ma distrib?
Commenter la réponse de repie007
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
0
Merci
Bonsoir,
pour WalterP, on ma donné la solution a mon problème sur un autre forum : comme solus a fonctionné sur mon pc j'ai relevé la version du noyau ex 4.20.16 dans mon cas et sous LM19 grâce au logiciel ukuu je l'ai installé,du coup ma GC a été reconnu,si çà peu vous aider
WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
-
Ok , merci repie007 ,
sur mon Pc Lenovo 310S/08asr le noyau 4.4 fonctionne , c'est le noyau d'Ubuntu 16.04.1 . Mais Fedora 29 avec un tout autre noyau ( 4.18 je crois , ou 5.0 ...) fonctionne aussi ! Donc ...

Intéressant le Logiciel UKUU ! Si je comprends bien ça peut permettre d'installer la distribution que l'on veut , mais avec un noyau différent . Oui c'est pas mal , car pour moi ( après différents essais sur un autre Pc ... ) c'est quand même Mint qui me convient le mieux !

Ok , merci repie007 pour le tuyau ! :)

Je viens de regarder un tutoriel sur ukuu , mais je n'ai pas compris ! On procède comment ?
WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
> WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
-
Fedora 29 Workstation , avec un noyau 5.0.13 - 200 . Fonctionne très bien sur mon Lenovo . Une distribution très agréable à utiliser , avec une logithèque bien fournie . A essayer ...
repie007
Messages postés
9
Date d'inscription
vendredi 10 mai 2019
Statut
Membre
Dernière intervention
12 mai 2019
-
apparemment plus le matériel du pc est récent plus la version du noyau doit l’être aussi et vice versa.Pour ukuu je l'ai installé depuis le terminal puis sur l'interface de ukuu j'ai choisi la version que je voulais ,en cas de bug au demarrage du pc j'ai le grub qui s'affiche et il me suffit de choisir sur quelle version je veux demarrer
Fedora fait partit des distrib que j'ai voulu tester mais j'ai eu un ecran noir a chaque fois,donc je l'ai mise de coté
WalterP
Messages postés
93
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
12 mai 2019
-
Ok , ça marche , en cas de besoin j'essaierai ukuu . Merci :)
Commenter la réponse de repie007