Menu

Formule si avec et

Messages postés
66
Date d'inscription
lundi 10 décembre 2012
Statut
Membre
Dernière intervention
11 mai 2019
- - Dernière réponse : PapyLuc51
Messages postés
1942
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 mai 2019
- 12 mai 2019 à 06:39
Bonjour,

Je butte sur une formule:
dans ma case A1 j'ai le mot "Gazoil" dans la case B1 la lettre "A" quand les deux sont conforme ca me donne le résultat da la case C2 si c'est faux ca me donne le résultat de la case C3
Ma formule =SI(ET(a1="Gazoil";b1="A");C2;C3)
Ca fonctionne.
Par contre quand je passe A1 "Gazoil" et que dans la case B1 la lettre "B" pour avoir le résultat de la case C4 et C5 ca marche pas j'ai essayé cette formule:
=SI(ET(a1="Gazoil";b1="A");C2;C3;SI(ET(a1=Gazoil";b1="B");c4;c5)
Ca fonctionne pas si vous aviez la solution, ce serait super !
Merci à tous
Afficher la suite 

Votre réponse

4 réponses

Meilleure réponse
Messages postés
10621
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 mai 2019
1283
1
Merci
Bonsoir

Tu as trop de cas pour les conditions possibles

Si A 1= gazoil , soit B1="A" alors C2, soit B1="B" alors C4 soit B1=autre chose alors ??
Et si A1 <> gazoil ??

Partant de là :
=SI(A1<>"Gazoil"; cellule du rendu en ce cas;SI(B1="A";C2;SI(B1="B";C4;cellule du rendu si ni A ni B)))

Par contre si tu as d'autres possibilités que gazoil à tester en A1 avec valeurs en B1 il vaut mieux passer par un tableau avec en lignes les valeurs possibles de A1 et en colonnes les valeurs possibles de B1
aux intersections les valeurs que peut prendre la cellule de résultat pour chaque cas.
Ensuite tu retrouves la bonne valeur avec =INDEX(tplage de toutes les valeurs du tableau;EQUIV(A1; plage des valeurs de A1 en 1ere colonne du tableau;0);EQUIV(B1;plage des valeurs de B1 en 1ere ligne du tableau;0))

Cdlmnt
Via

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39463 internautes nous ont dit merci ce mois-ci

dada54
Messages postés
66
Date d'inscription
lundi 10 décembre 2012
Statut
Membre
Dernière intervention
11 mai 2019
-
Bonjour via55,

Merci mais je n'y arrive pas a faire la formule j'essais de t'envoyer mon tableau pour que tu puisses me comprendre.
dada54
Messages postés
66
Date d'inscription
lundi 10 décembre 2012
Statut
Membre
Dernière intervention
11 mai 2019
-
J'aimerai t'envoyer mon tableau comment je fais?
Commenter la réponse de via55
Messages postés
10621
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 mai 2019
1283
0
Merci
Bonsoir

Tu postes ton fichier sur mon-partage.fr, tu fais créer un lien que tu copies et reviens coller ici
Je regarderai ça
dada54
Messages postés
66
Date d'inscription
lundi 10 décembre 2012
Statut
Membre
Dernière intervention
11 mai 2019
-
https://mon-partage.fr/f/WGF5dZEc/

Merci via55

Bon week!
Commenter la réponse de via55
Messages postés
48892
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 mai 2019
9882
0
Merci
Bonsoir dada54.

Ta formule =SI(ET(a1="Gazoil";b1="A");C2;C3;SI(ET(a1=Gazoil";b1="B");c4;c5) est fausse :
- il manque le premier guillemet du second Gazoil ;
- tu ne dois avoir que 2 points-virgules pour séparer les 3 items de la fonction SI ;
- tu dois avoir autant de parenthèses fermantes que d'ouvrantes, donc 3 !

Tu devrais donc avoir
soit =SI(ET(A1="Gazoil";B1="A") ; C2 ; SI(ET(A1="Gazoil";B1="B") ; C4 ; C5))
soit =SI(A1="Gazoil" ; SI(B1="A" ; C2 ; C5) ; SI(B1="B") ; C4 ; C3)))
soit quelque chose de semblable ...

Via55 et moi souhaitons savoir
Si A1 = "Gazoil" et B1="A" on obtient quoi ? C2 ?
Si A1 = "Gazoil" et B1="B" on obtient quoi ? C5 ?
Si A1<>"Gazoil" et B1="A" on obtient quoi ? C3 ?
Si A1<>"Gazoil" et B1="B" on obtient quoi ? C4 ?

En fait, il te suffit de compléter tes informations en J15 et J16 !

C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)
Commenter la réponse de Raymond PENTIER
Messages postés
1942
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
21 mai 2019
354
0
Merci
Bonjour,
D'après ton tableau et s'il n'y a que ces 4 données ;

si D4 = Gazoil et I4 = A resultat Q4
si D4 = Essence et I4 = A resultat Q4
si D4 = Gazoil et I4 = B resultat R4
si D4 = Essence et I4 = B resultat R4


Alors je propose cette formule

=SI(ET(I4="A";OU(D4="Gazoil";D4="Essence"));Q4;R4)

Salutations à via55 & Raymond PENTIER

Cordialement
Commenter la réponse de PapyLuc51