Menu

Exporter les données d'un classeur A pour un classeur B

- - Dernière réponse :  ANGUICAM - 13 mai 2019 à 10:05
Bonjour,

J'ai un classeur A dans lequel il y a des feuilles A1, A2, A3 et je voudrais avoir un classeur B dans lequel certaines données de A1, A2 et A3 de déversent au fur et à fur qu'elle sont renseignées. J'ai tenté une formule avec le lien mais le système me signale l'absence d'un argument. Je suis vraiment débutante sur excel et les formules. si quelqu'un peut m'aider svp.
=IMPORTRANGE("https://docs.google.com/spreadsheets/d/1R--P5MqgdDJ8YbXVEAUqNoeJlppht0R7wsBYogdoraY/edit#gid=56179398""(RECHERCHEV(E2;RECHERCHEV(Saisies Accueil!C:E;F;)'Critères'!$D$2:$D$35))")
Afficher la suite 

Votre réponse

2 réponses

Messages postés
48887
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 mai 2019
9882
0
Merci
Bonjour.

Tu ne le sais peut-être pas, mais il existe de nombreuses versions d'Excel.
Certaines sont installées dans l'ordinateur, d'autres sont à utiliser en ligne, c'est-à-dire via Internet.
Tu as négligé de préciser quelle était ta version ; mais c'est certainement une version en ligne, car la fonction IMPORTRANGE n'existe pas dans les versions installées ...

"Absence d'argument" nous renvoie forcément à la fonction RECHERCHEV.
Tu dois savoir que la syntaxe de cette fonction est RECHERCHEV(arg1 ; arg2 ; arg3 ; arg4) dans laquelle :
arg1 est la valeur cherchée,
arg2 est la matrice de recherche,
arg3 est le N° de colonne (de la matrice) où se trouve l'information
arg4 qui vaut 0 ou 1 (selon que la première colonne est triée ou non).
Ce dernier argument est optionnel, mais les 3 premiers sont obligatoires.

Or quand tu écris
RECHERCHEV(E2 ; RECHERCHEV(Saisies Accueil!C:E;F;)'Critères'!$D$2:$D$35)
arg1 est ici E2
arg2 serait RECHERCHEV(Saisies Accueil!C:E;F;)'Critères'!$D$2:$D$35
arg3 serait inexistant ! Première erreur ...
Commenter la réponse de Raymond PENTIER
Messages postés
48887
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 mai 2019
9882
0
Merci
... (suite)
Si on considère maintenant la seconde fonction
RECHERCHEV(Saisies Accueil!C:E;F;)'Critères'!$D$2:$D$35), son argument 1 est
Saisies Accueil!C:E;F;)'Critères'!$D$2:$D$35
... On peut imaginer que tu voulais écrire les arguments 1 et 2, et alors il manque un point-virgule :
Saisies Accueil!C:E;F;) ; 'Critères'!$D$2:$D$35
...

De toutes façons, tu dois tout reprendre, en respectant scrupuleusement la syntaxe de la fonction, et suivre le modèle =RECHERCHEV(arg1 ; RECHERCHEV(argA;argB;argC) ; arg3)
Bonjour,
Je travaille effectivement en ligne. j'ai téléchargé le fichier sous format excel et je vais essayer d'appliquer tes conseils. Merci d'avance.
Commenter la réponse de Raymond PENTIER