Menu

Somme de valeurs des 7 jours précédents

Messages postés
3
Date d'inscription
mardi 7 mai 2019
Statut
Membre
Dernière intervention
8 mai 2019
- - Dernière réponse :  JOHEL_9081 - 8 mai 2019 à 20:52
Bonjour,
J'ai dans une feuille excel une colonne avec des dates (colonne B) et une autres avec des ditances (colonne F sur la photo ci-dessous)
je souhaiterai faire une somme en colonne L des distances effectuées sur les 7 jours précédents.

Les difficultés étant que :
- certaines dates sont présentes deux voire trois fois (2 voire 3 lignes avec la même date) donc je ne peux pas pfaire à chaque fois la somme des 7 lignes précédentes.
- je voudrais pouvoir déployer la formule de la case Somme (en jaune sur la photo) afin d'avoir des totaux pour chaque date faisant abstraction du point évoqué ci-dessus.

Merci pour votre aide....... (je m'y prends la tête depuis plusieurs jours...)
Afficher la suite 

Votre réponse

8 réponses

Messages postés
1635
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
19 mai 2019
358
0
Merci
Bonsoir
une proposition

=SOMMEPROD(B$2:B2>B2-7;C$2:C2)
Commenter la réponse de yclik
Messages postés
8
Date d'inscription
mercredi 23 avril 2008
Statut
Membre
Dernière intervention
19 mai 2019
1
0
Merci
Bonjour
J'espère avoir répondu à ton problème...
https://cjoint.com/c/IEhpxGj3Thb

Saisir la date de début (la date de fin =date debut+7)
A+ François
Commenter la réponse de franc38
Messages postés
641
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
23 mai 2019
63
0
Merci
Bonsoir
A tester
=SOMME.SI(A:A;">"&AUJOURDHUI()-7;B:B)-SOMME.SI(A:A;">"&AUJOURDHUI();B:B)
Cordialement
Commenter la réponse de JCB40
Messages postés
23967
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 mai 2019
4591
0
Merci
Bonjour
(et salut iclik)
le principe est bon, mais SOMMEPROD nécessite une multiplication, pas un point virgule:
soit sur ligne 7 si la liste commence en ligne 2
=SOMMEPROD(($B$2:B7>B2-7)*($C$2:C7))
il faut bien sur que la liste de date soit classée en croissant, sinon écrire, pour un champ de ligne 2 à 1000
=SOMMEPROD(($B$2:$B$1000>B2-7)*($B$2:$B$1000<=B2)*($C$2:$C$1000))

crdlmnt


Commenter la réponse de Vaucluse
Messages postés
3
Date d'inscription
mardi 7 mai 2019
Statut
Membre
Dernière intervention
8 mai 2019
0
Merci
Bonjour et Merci pour vos réponses......
merci particulièrement à Franc38. Je viens de faire un test rapide avec ta formule et cela semble convenir. Il me faut maintenant tenter de la déployer sur toutes mes données.

Merci à tous.
Commenter la réponse de JOHEL_9081
Messages postés
3
Date d'inscription
mardi 7 mai 2019
Statut
Membre
Dernière intervention
8 mai 2019
0
Merci
Re-bonjour,
je reviens vers vous car à la suite de la prise en compte de vos réponses, j'essaie maintenant d'optimiser au mieux mon tableau afin de réduire les actions nécessaire à l'avenir.

Pour la date de fin, je souhaiterais que la cas se complète automatiquement en utilisant la date de début - 7 jours (ou autre : -1 mois, -6 mois,...) . J'ai trouvé dans excel la possibilité de le faire avec la formule "SERIE.JOUR.OUVRE" mais je souhaiterais prendre en compte toutes les dates et non seulement les jours ouvrés.
Que puis-je utiliser ?

Merci
Commenter la réponse de JOHEL_9081
Messages postés
8
Date d'inscription
mercredi 23 avril 2008
Statut
Membre
Dernière intervention
19 mai 2019
1
0
Merci
Bonjour

La date de fin doit être plus petite que la date du début?
Explication de ma proposition:
en B10 (tu peux choisir une autre cellule) on a
=SOMME.SI.ENS(B1:B9;A1:A9;F9;A1:A9;F10) tu peux mettre =SOMME.SI.ENS(B1:B99;A1:A99;F9;A1:A99;F10) ou autre
b1:b9 c'est les cellules à additionner
a1:a9 c'est les cellules qui doivent répondre aux critères
f9 (masquées) comprend: les signes" >=" + la date de début
f10 (masquées) comprend: les signes" "<="+ la date de fin
en E10 on a la date de début+7

J'espère que tu pourras régler ton problème avec ces renseignements...
A+ François
Commenter la réponse de franc38
0
Merci
Merci beaucoup pour ces informations.
Je reprendrais mes essais durant le prochain week-end.
Je pense être proche de mon objectif en utilisant des informations (formule) dans des colonnes masquées.
Merci encore
Commenter la réponse de JOHEL_9081