Menu

Besoin de votre aide pour une formule à 2 criteres.

Messages postés
4
Date d'inscription
lundi 6 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
- - Dernière réponse : eriiic
Messages postés
22715
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
9 mai 2019
- 6 mai 2019 à 23:56
bonjour j'aimerai votre aide svp...
j'ai le tableau suivant qui me sert de base

Nbr de personnes montant 1 montant 2
1 8500 10800
2 12400 16840
3 15800 18650


Je voudrais obtenir ce type de résultat dans la case qualité: A savoir que ca teste la condition nombre de personne et ensuite le montant...
si le montant est inferieur à montant 1 => faible
si le montant est compris entre montant 1 et montant 2 => Moyen
Sinon HC

Montant Nbr de pesonnes Qualité
6500 1 Faible
14500 2 Moyen
12550 1 HC
16550 3 MOyen

je vous remercie par avance de votre aide précieuse.
Afficher la suite 

Votre réponse

2 réponses

Messages postés
1736
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
9 mai 2019
656
0
Merci
Bonjour,

On va tenté avec ça. Considérer la colonne A comme le montant, B comme Le nombre de personne et C ... la colonne de résultat.

En C2:
=Si(A2=1;Si(B2<8500;"Faible";Si(B2<10800;"Moyen";"HC"));Si(A2=2;Si(B2<12400;"Faible";Si(B2<16840;"Moyen";"HC"));Si(B2<15800;"Faible";Si(B2<18650;"Moyen";"HC"))))

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
johnaz
Messages postés
4
Date d'inscription
lundi 6 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
merci pour ta reponse..
mais je pense que la réponse est plus complexe que cela.. en effet mon tableau de base contient bien plus de ligne que ce que j'ai mis dans mon exemple.. et je voudrais appliquer cela de façon automatique sur toute une base de données.. un truc du genre rechercheV peut etre.. combiné avec une autre fonction qui calcule automatiquement le résultat en fonction de 2 critéres qu'elle test nbr de personnes et montant..
Commenter la réponse de diablo13800
Messages postés
22715
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
9 mai 2019
7366
0
Merci
Bonjour,

avec ton tableau en G2:I4 :
=SI(A2<RECHERCHEV(B2;$G$2:$I$4;2;0);"Faible";SI(A2<RECHERCHEV(B2;$G$2:$I$4;3;0);"Moyen";"HC")) 

voit si tu préfères <= (?!?)

La prochaine fois dépose un fichier de travcail sur cjoint.com et colle ici le lien fourni.
Tu auras plus de réponses...
eric
Commenter la réponse de eriiic