Menu

Fonction SI [Résolu]

-
bonjour, je me casse la tête avec la fonction SI.

A B C D
BLAXL020 B LA 15
BLAXS021 B LA 15
BMAXS006 B MA 18
BMAXS007 B MA 18
BMOXS001 B MO 20
BMOXS001 B MO 20
BQU5FXS001 B QU 16
BQU5FXS001 B QU 16

Quant la cellule B contient B et la cellule C contient LA, la valeur de la cellule D doit être 15
Quant la cellule B contient B et la cellule C contient MA, la valeur de la cellule D doit être 18
Quant la cellule B contient B et la cellule C contient MO, la valeur de la cellule D doit être 20
Quant la cellule B contient B et la cellule C contient QU, la valeur de la cellule D doit être 16

Ok pour ce type de formule =SI(ET(B2="B";C2="LA");"15";""), mais elle me donne que la valeur de la ligne 1 et 2, le reste des lignes est vide.
j'ai essayé de faire: =SI(ET(B2=B;C2=LA; C2=MA;C2=MO; C2=QU);("15;18;20;16");("";"";"";"")), mais cela ne marche pas.
aussi: =SI(ET(B2="b";C2="LA");"15";"");SI(ET(B$="b";C2="MA");"18";"")

Valeur logique: B2=B;C2=LA; C2=MA;C2=MO; C2=QU
Valeur si vrai: 15;18;20;16
valeur si faux: ("";"";"";"")
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
Messages postés
48871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2019
16142
1
Merci
Bonjour.

Tu es un peu distrait ? Ta formule fonctionne parfaitement !
Si tu n'as pas "LA" en colonne C elle affiche "" ;
c'est bien ce que ta formule =SI(ET(B2="B";C2="LA");15;"") demande !
Et cela fonctionne :
Remplace "" par "@" pour bien visualiser ...


Tes 3 dernières lignes "Valeur ..." servent à quoi ?
C'est bien, la retraite ! Surtout aux Antilles ... 
Raymond (INSA, AFPA)

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39092 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Raymond PENTIER
Messages postés
23961
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 mai 2019
5788
1
Merci
Bonjour
sous réserve de bonne compréhension:
=SI( B2<>"B";"",SI(C2="LA";15;SI(C2="MA";18;SI(C2="MO";20;SI(C2=QU;16;"")))))

ou encore:
=SI(B2&C2="BLA";15;SI(B2&C2="BMA";18;SI(B2&C2="BMO";20;SI(B2&C2="BQU";16;""))))
crdlmnt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39092 internautes nous ont dit merci ce mois-ci

Merci, ça a marché la deuxième formule!

Vous m'avez sauvée, car depuis plusieurs jours j'essaye et rien! Disons que je ne suis pas l'experte en excel:(
Commenter la réponse de Vaucluse
Messages postés
48871
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2019
16142
1
Merci
Pour traiter les 4 possibilités, il faut compléter la formule de départ avec les 3 autres conditions :
=SI(ET(B2="B";C2="LA");15; SI(ET(B2="B";C2="MA");18; SI(ET(B2)="B";C2="MO");20; SI(ET(B2="B";C2="QU");16;""))))

Et pour optimiser la formule, on préférera
=SI(B2<>"B";"";SI(C2="LA";15;SI(C2="MA";18;SI(C2="MO";20;SI(C2="QU";16;"")))))

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39092 internautes nous ont dit merci ce mois-ci

Commenter la réponse de Raymond PENTIER