Menu

Empêcher le fractionnement du tableau sur plusieurs pages

Messages postés
4
Date d'inscription
jeudi 2 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
- - Dernière réponse : RobertGregoire
Messages postés
4
Date d'inscription
jeudi 2 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
- 7 mai 2019 à 15:13
Bonjour,
J'ai beau chercher dans Internet, je n'arrive pas à empêcher mon tableau Word (Office 365 ProPlus) de se séparer sur plusieurs pages dès que j'ajoute un [Styles => Titre] à une ligne. Tous les conseils pointent vers [Outils de tableau => Propriétés => Onglet ligne => Autoriser le fractionnement des lignes sur plusieurs pages] (cocher).
Pourtant, cette option est bien cochée et quand je formate avec un Titre, pouf! ça renvoie la ligne à une nouvelle page.
Quelqu'un sait comment empêcher cela?
Merci d'avance, Robert
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
15193
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
11695
1
Merci
Bonsoir,

Difficile d'en dire plus sans voir le document et le tableau...

Y a quand même un truc qui me paraît illogique : tu dis avoir coché l'option "Autoriser le fractionnement des lignes sur plusieurs pages"... si c'est coché, c'est l'effet inverse de ce que tu recherches...

m@rina

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39326 internautes nous ont dit merci ce mois-ci

RobertGregoire
Messages postés
4
Date d'inscription
jeudi 2 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
Bonjour Marina,

Ce paramètre me confond moi aussi. Mais voici la manière dont je le comprends: lorsque l'option est cochée, si la ligne de ton tableau s'étend sur la page suivante, le tableau reste joint et la ligne se continue sur la page suivante, sans rompre la continuité du tableau. Ça fonctionne exactement comme prévu jusqu'à ce que j'utilise un style de titre dans la ligne. Je pense que tu pourrais assez facilement reproduire le trouble sans que je publie le document, mais je me ferai un plaisir d'en créer un bidon si cela peut aider. Je pense que Bouda08 présente une bonne explication possible, même si je ne vois rien dans le style de titre qui explique ce comportement.

Merci!
Robert
m@rina
Messages postés
15193
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
20 mai 2019
11695 -
Bonjour Robert,

Quand cette option est cochée, cela signifie clairement qu'une ligne de tableau pourra être coupée si le tableau arrive en bas de page. On parle bien de cellule, pas d'une ligne à l'intérieur d'une cellule.

Si l'on ne souhaite pas qu'une cellule soit coupée, il ne faut pas cocher cette option. Si le tableau est trop grand pour tenir sur la page, la coupure se fera, mais entre les cellules.

Certaines choses peuvent empêcher cela : par exemple s'il y a des cellules fusionnées verticalement. Même si l'option n'est pas cochée, il y a un risque qu'une telle cellule soit coupée.

Ton problème avec le style peut effectivement provenir du style lui-même. Si ce style comprend un saut de page avant, le tableau sera automatiquement coupée et renvoyé sur la page suivante. Et dans les propriétés que tu donnes de ce style, tu as omis cette précision qui est la plus importante...

Mais, au risque de me répéter, l'option "Autoriser le fractionnement des lignes sur plusieurs pages" signifie qu'on accepte une coupure de cellule en bas de page lorsque le contenu de la cellule est trop long pour rester sur la même page.

Je veux bien voir l'exemple, même bidon !

m@rina
RobertGregoire
Messages postés
4
Date d'inscription
jeudi 2 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
Bonjour Marina,

Merci pour tous ces détails! J'ai cherché à reprendre ces mêmes documents qui posaient problèmes et à effectuer la manœuvre qui causait ce comportement, soit dans un tableau fractionné sur deux pages de changer le Titre en cellule 1 de ligne au style normal ou, dans un tableau où je me suis résigné à ne pas utiliser le style pour empêcher le fractionnement et à lui appliquer un style... Et juste pour mal faire, le comportement décrié ne se reproduit pas!?! Je serai curieux de vérifier dans un nouveau document si cela survient de nouveau, car j'ai "bûché" sur ce problème à quelques reprises, jusqu'à ce que j'en sois venu à cerner que c'est l'ajout du style Titre qui cause problème. Au point où je peux reproduire le style Titre sans en utiliser la fonction et cela n'entraîne pas le fractionnement du tableau. Tout cela est bien étrange. Je dois travailler aujourd'hui à ce même genre de document et je reviendrai confirmer que le problème subsiste, le cas échéant. Pour le moment, je ne suis toutefois pas en mesure de vous créer un document bidon, puisque mes modèles de base ne semblent plus se comporter de manière à causer problème.

Merci à vous et au plaisir,
RG
Commenter la réponse de m@rina
0
Merci
Bonjour,

C'est peut être ton style titre qui cause ce fractionnement.
RobertGregoire
Messages postés
4
Date d'inscription
jeudi 2 mai 2019
Statut
Membre
Dernière intervention
7 mai 2019
-
Voici le style (défaut Word):
[Retrait :
Gauche : 0,07 cm
Suspendu : 0,25 cm
Interligne : simple, Niveau 2, Avec puces + Niveau : 1 + Alignement : 0,71 cm + Retrait : 1,35 cm, Style : Lié, Masquer jusqu'à utilisation, Afficher dans la galerie Styles, Priorité : 10
Sur base de : Paragraphe de liste
Style suivant : Normal]
Vous y voyez une raison de renvoyer la ligne à la page suivante, en priorité des propriétés de tableau? Pour ma part, je ne vois pas quoi changer dans ces propriétés de titre...
Merci d'avance!
- Robert
Commenter la réponse de Bouda08