Menu

Excel: compter le nombre de numéros commençant par... [Résolu]

- - Dernière réponse :  IRudiq - 29 avril 2019 à 12:05
Bonjour à tous:

Dans le cadre de mon entreprise, je dois être capable d'identifier combien de clients nous appellent depuis leur portable ou leurs fixe.

Je me retrouve donc avec une collecte de données client sur Excel comprenant le numéro depuis lequel ils nous ont appelé et je dois maintenat les compter.

Seul problème: lorsque j'utilise la fonction "countif" (=countif(range des data;"336*")) j'obtiens continuellement 0 en valeur.

Sauriez-vous ce que je ne fais pas correctement?

Merci par avance pour votre aide et bonne journée à vous tous !
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
1923
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
13 mai 2019
206
1
Merci
Bonjour

Pour comptabiliser tous les N° commençant par 336
=SI(GAUCHE(range des data;3)="336";NB(range des data)), à valider avec CTRL + SHIFT + ENTREE

A adapter pour les autres numéros.

Cdlt

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39162 internautes nous ont dit merci ce mois-ci

Bonjour Frenchie83,

Merci pour ta réponde rapide.
Je viens d'essayer avec cette fonction: =IF(LEFT('Data appels mois de Mars 2019'!G2:G407;3)="336";COUNT('Data appels mois de Mars 2019'!G2:G407))
en m'assurant de valider comme tu l'as précisé mais ils me donnent comme résultat "FALSE".

J'ai auparavant changé le format des nombre en passant de "numéro de téléphone" à "nombre" en me disant que le problème venait peut-être de là mais ça n'a rien changé du tout.
Commenter la réponse de Frenchie83
Messages postés
45
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
25 mai 2019
8
1
Merci
Bonjour,
J'imagine que vos numéros de téléphone sont en colonne a1:a500. Vous pourriez ajouter une colonne en B1avec la formule =gauche(a1;3) tirée sur toute la colonne, qui sortirait donc les 3 premiers chiffres.
Ensuite une formule =NB.SI(a1:a500;336)
Cordialement.

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 39162 internautes nous ont dit merci ce mois-ci

Bonjour Victor-92,

Merci beaucoup pour votre aide, cette solution fonctionne effectivement.

Votre aide à sauvé une vie ! ;)

Bonne journée
victor-92
Messages postés
45
Date d'inscription
lundi 22 avril 2019
Statut
Membre
Dernière intervention
25 mai 2019
8 -
Votre boss est si méchant ?
Commenter la réponse de victor-92