MFC si date comprise dans liste [Résolu]

Messages postés
589
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
5 juillet 2019
- - Dernière réponse : Nai
Messages postés
589
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
5 juillet 2019
- 28 avril 2019 à 20:35
Bonsoir toutes et tous !
Je cherche à modifier le fond d'une cellule contenant une date si cette date est comprise dans une liste d'une autre feuille. Les cellules de la MFC sont fusionnées, peut-être n'est-ce pas possible.
Dans la feuille "Prévisionnel", j'ai 4 semaines dans des colonnes. Je voudrais que certaines de ces dates soient mises en valeur selon quelques dates de la feuille "Renseignements". Il s'agit en l'occurrence des dates de sorties.
Voir le fichier, c'est peut-être plus parlant.

Je verrais plus tard pour faire apparaître les jours fériés (que l'utilisateur final cochera dans la feuille "Renseignements".

Merci de votre aide !

https://www.cjoint.com/c/IDCryrBJZNi

Configuration: Windows 7 (64 bits)
Google Chrome (dernière version)
Intel(R) Core(TM) i7 CPU
2.4GHz
Mémoire 8,00 Go

Afficher la suite 

1 réponse

Messages postés
10968
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
17 août 2019
1371
0
Merci
Bonjour

Selectionne H8:CI25 puis Nouvelle règle de MFC - Utiliser une formule et entrer :
=NB.SI(Renseignements!$A$41:$A$42;H$8)>0
ATTENTION pas de $ devant H pour que la MFC s'applique à toutes les colonnes

Le mieux serait donner un nome aux cellules de la plage des sorties dans Renseignements et adapter le nom s'il y a plus de 2 dates et utiliser ce nom dans la formule au lieu de $A$41:$A$42, ainsi si on change la plage de dates de sorties il suffit de modifier la référence dans le gestionnaire d enoms sans avoir à reprendre les formules de MFC

Cdlmnt
Via
Nai
Messages postés
589
Date d'inscription
vendredi 29 avril 2005
Statut
Membre
Dernière intervention
5 juillet 2019
45 -
=NB.SI(Renseignements!$A$41:$A$42;H$8)>0
Fonctionne parfaitement ! Merci !
Le mieux serait donner un nom aux cellules de la plage des sorties dans Renseignements et adapter le nom s'il y a plus de 2 dates et utiliser ce nom dans la formule au lieu de $A$41:$A$42, ainsi si on change la plage de dates de sorties il suffit de modifier la référence dans le gestionnaire de noms sans avoir à reprendre les formules de MFC
La plage n'est pas amenée à être modifié. J'envisage 4 sorties, voire 6 ^^
Mais en effet, je nommerais certainement la plage ultérieurement :)

Merci !
Commenter la réponse de via55