SI cellule vide alors montant en négatif [Résolu]

- - Dernière réponse : PapyLuc51
Messages postés
1994
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 juillet 2019
- 26 avril 2019 à 12:11
Salut à Tous,

Je cherche le moyen de faire la chose suivante:

Si une cellule est vide alors (autre cellule) montant en négatif.
Si cette cellule est remplie, alors le montant sera en positif.

Les formules suivantes ne fonctionnent pas:

=SI(H9="";(D9:E9)*-1;D9:E9)
=SI(H9="";=SOMME(D9:E9)*-1;=SOMME(D9:E9)

Sachant que la cellule (contenant le montant) est une formule simple genre =SOMME(D9:E9)

Pourriez-vous m'aider?

Je vous remercie pour votre aide !
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
1994
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 juillet 2019
382
1
Merci
Bonjour

Comme ceci ça devrait aller

=SI(H9="";-SOMME(D9:E9);SOMME(D9:E9))

Cordialement

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 55038 internautes nous ont dit merci ce mois-ci

Si simple... je me sens si stupide !

Un énorme merci pour votre aide :)
PapyLuc51
Messages postés
1994
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
20 juillet 2019
382 > mjcourier -
Ravi d'avoir aidé,
Toutefois cette formule ne s'applique que si la somme D9+E9 est positive sinon le résultat attendu sera le contraire positif si H9 est vide et négatif si H9 est renseigné.

Alors si la somme est toujours positive il n'y a rien à changer, sinon si tu tiens absolument à un nombre négatif si H9 est vide et que la somme D9+E9 est négative il faut cette formule

=SI(H9="";SI(SOMME(D9;E9)<0;SOMME(D9:E9);-SOMME(D9:E9));SI(SOMME(D9;E9)<0;-SOMME(D9:E9);SOMME(D9:E9)))

Cordialement
Commenter la réponse de PapyLuc51