Menu

Formule avec nombre de valeurs variables

Messages postés
17
Date d'inscription
vendredi 15 septembre 2017
Statut
Membre
Dernière intervention
18 avril 2019
-
Bonjour,
J'ai créé un tableau pour faire des petits inventaires dans la boutique ou je travaille. J'ai fait un tableau sur 50 Lignes, mais je peux très bien n' avoir à rentrer que 10 lignes de données. Pour la plupart des formules des colonnes de mon tableau, en mettant "= si vide" au début de ma formule, ça marche, mais j'ai voulu fusionner les doublons avec la formule =SI(LIGNE()-1<=$E$2;INDEX($A$1:$A$50;PETITE.VALEUR(SI(NB.SI($F$1:F1;A2:A50)=0;LIGNE(A2:$A$50);999);1));"") celà fonctionne, mais elle me met #rèf# en dernière ligne des résultat. De plus, j'ai aussi fait une colonne pour additionner les quantités du stock après élimination des doublons avec la formule : =SI(F2<>"";SOMMEPROD(($A$2:$A$50=F2)*$B$2:$B$50);"")) Mais cela ne fonctionne que si j'indique exactement le nombre de ligne et cela m'écrit "Valeur" si je laisse la formule tel quel. Comment peut on indiquer dans une formule que le nombre de données peut être variable au lieu d'avoir à modifier la formule chaque fois que j'ai besoin du fichier. Ma formule ne comprend pas pourquoi je met une plage de A2 à A50 alors que je n'ai que 10 lignes d'occupées. J'espère avoir réussi à être claire dans mes explications. Dés demain j'essaierais d'insérer une image dans ce post pour que ce soit plus clair. Merci.
Afficher la suite 

Votre réponse

2 réponses

Messages postés
23856
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 avril 2019
5760
0
Merci
Bonjour
  • on a du mal à comprendre ce que vous voulez faire avec <NB.SI(F1:F1;A2:A50)... pouvez vous expliquer mieux
  • D'autre part entrez vous cette formule en matricielle, auquel cas NB.SI peut ne pas fonctionner?
  • si vous le pouvez plutôt qu'une image déposez un modèle Excel avec quelques explications ici:

http://mon-partage .fr
et revenez coller le lien créé sur le site
à vous lire
crdlmnt

Fourmini84
Messages postés
17
Date d'inscription
vendredi 15 septembre 2017
Statut
Membre
Dernière intervention
18 avril 2019
-
Plutot que de m'embrouiller dans des formules (ci-dessus) dont je ne maîtrise pas tout, j'ai créé un fichier pour exemple simplifié de ce que j'ai comme infos et ce que je voudrais pouvoir faire : https://mon-partage.fr/f/AcHk99CT/
Merci.
Commenter la réponse de Vaucluse
Messages postés
8882
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
18 avril 2019
1930
0
Merci
Bonjour à tous les deux

Un exemple avec plages dynamiques
https://mon-partage.fr/f/YopR9Uzr/

Cdlmnt
Commenter la réponse de ccm81