Menu

Additionner si les premiers caractères sont identiques [Résolu]

Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
-
Bonjour à tous,



J'aimerais savoir s'il est possible d'intégrer dans une fonction SOMMEPROD, la fonction GAUCHE. En effet, j'aimerais pouvoir additionner toutes les quantités présentes dans le tableau, lorsque que ma cellule D9 est égale au 9 premiers caractères de la ligne 2.
Dans mon exemple, pour la valeur A, je souhaiterais obtenir 10 (B3 + D3) et non 5 (B3)

Voici ma formule actuelle en D10 :
=SOMMEPROD((($A$3:$A$6)=C10)*($B$3:$E$6)*(($B$2:$E$2)=$D$9)), je pensais qu'en intégrant la fonction GAUCHE dans la matrice ($B$2:$E$2) cela fonctionnerait mais non...
Existe-t-il une solution répondant à ma demande ?

Merci de votre aide :)
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
23837
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 avril 2019
5755
2
Merci
Bonjour
et pourtant ça devrait finctioçnner
A toutes fins utiles,voyez avec cette variante

=SOMMEPROD((GAUCHE($B$2:E2;NBCAR(D$9))=D$9)*($A$3:$A$6=$B10)*($B$3:$E$6))
crdlmnt



Dire « Merci » 2

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 41454 internautes nous ont dit merci ce mois-ci

Coco-8
Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
1 -
Parfait ça marche niquel !
Je voulais pas passer par une ligne intermédiaire qui me renvoie les 9 premiers caractères merci de m'avoir trouvé une solution :)
Commenter la réponse de Vaucluse