Menu

Formule qui fait apparaitre le titre de la colonne [Résolu]

Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
-
Bonjour à tous,

Je recherche une formule qui, à priori semble simple, mais que je galère à trouver...
J'aimerais faire apparaitre le titre de mes colonnes si sa cellule associée est différente de zéro.

Exemple : (en rouge ce que je cherche à obtenir par une formule)


Avec la fonction SI j'ai trouvé à peu près quelque chose de correcte, mais dans certains cas elle me renvoie des signes " + " au début/a la fin alors qu'il n'y a pas de ville qui le précède/le succède

Merci à ceux qui prendront le temps de répondre à mon problème :)
Afficher la suite 

Votre réponse

3 réponses

Messages postés
23854
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 avril 2019
5759
0
Merci
Bonjour

c'est probablement parce que vous n'avez pas inclus le + dans les conditions:

=SI(A2>0;$A$1;"")&SI(B2>0;"+"&$B$1;"")&SI(C2>0;"+"&$C$1;"")&SI(D2>0;"+"&$D$1;"")

crdlmnt

Coco-8
Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
1 -
Merci Vaucluse,
Ta formule me renvoie la même erreur que la mienne, pour la dernière ligne elle me renvoie "+PARIS+MARSEILLE+LILLE", il y a donc le "+" devant PARIS en trop...
Saurais-tu où est le problème ?
Commenter la réponse de Vaucluse
Messages postés
560
Date d'inscription
lundi 2 juillet 2018
Statut
Membre
Dernière intervention
17 avril 2019
56
0
Merci
Bonjour à tous les 2

Formule à tester

=SI(A2>0;$A$1;"")&SI(B2>0;" "&$B$1;"")&SI(C2>0;" "&$C$1;"")&SI(D2>0;" "&$D$1;"")
Crdlt
Coco-8
Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
1 -
Merci JCB40,
Il n'y a pas les + dans les résultats de ta formule, et le signe "+" à un importance pour le reste de mon fichier..
En les rajoutant dans ta formule, ça me renvoie le même problème avec +PARIS
Commenter la réponse de JCB40
Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
1
0
Merci
Pour ceux à qui la formule peut servir, voici une solution que j'ai trouvé et qui fonctionne :
=SI(A2>0;$A$1;"")&SI(ET(A2>0;SOMME(B2:D2)>0);" + ";"")&SI(B2>0;$B$1;"")&SI(ET(B2>0;SOMME(C2:D2)>0);" + ";"")&SI(C2>0;$C$1;"")&SI(ET(C2>0;D2>0);" + ";"")&SI(D2>0;$D$1;"")

Merci à Vaucluse et JCB40
Commenter la réponse de Coco-8