Menu

Remplacer plusieurs SI imbriqués

Messages postés
392
Date d'inscription
samedi 26 août 2006
Statut
Membre
Dernière intervention
11 avril 2019
- - Dernière réponse : Vaucluse
Messages postés
23880
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
- 11 avril 2019 à 09:49
Bonjour,
:
Dans une de mes formules, j'ai plusieurs SI imbriqués : selon les valeurs en E2 et H2, la valeur dans la cellule E3 n'est pas la même.
Concrètement :
dans E2 et dans H2 : la valeur peut être régional ou départemental
dans E3 : selon les 3 cas possibles (régional-régional, régional-départemental, départemental-départemental), la valeur dans E3 n'est pas la même.

J'ai la solution facile en mettant 2 SI imbriqués mais je me demandais s'il n'existait pas une fonction plus adaptée (un genre de CASE en programmation).

Merci

PS : dans cet exemple je n'ai que 2 SI imbriqués mais il m'arrive d'en avoir 4 ou 5.

Configuration: Windows / Firefox 66.0
Afficher la suite 

Votre réponse

2 réponses

Messages postés
8898
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
24 avril 2019
1935
0
Merci
Bonjour

Un petit exemple avec la fonction CHOISIR
https://www.cjoint.com/c/IDlhWE2VKqB

Cdlmnt
Commenter la réponse de ccm81
Messages postés
23880
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
5769
0
Merci
Bonjour
le plus simple devrait être de faire un tableau des cas de figure avec les combinaisons possibles par exemple en Y1:Y20 (ou plus) en regroupant en écrivant en Y1:
  • Régional-Départemental etc...

la formule deviendrait alors:
=RECHERCHEV(E2&"-"&H2;Y:Z;0)
crdlmnt

Commenter la réponse de Vaucluse