Menu

Excel : Fonctions imbriquées - si et recherchev [Résolu]

- - Dernière réponse :  agathe - 11 avril 2019 à 15:55
Bonjour,

Je suis dans un tableau excel mes actions de communication.
J'ai une ligne par action de communication engagée (lignes 37 à 76).
- une colonne B, "category" (= premium, vip...) - B37:B76
- une colonne E "type of media" (pub, tv...) - E37:E76
- une colonne G "budget" (=avec combien ca m'a couté) - G37:G76

Sur la même feuille excel, je voudrais un petit tableau récap', qui me reporte le "budget" de toutes les actions de communication qui remplissent 2 critères à la fois.

Par exemple:
la somme de budget des actions qui sont à la fois "category=Premium" et à la fois "type of media=TV".
càd
D5 = si "PREMIUM" sur B37:B76 ET si "TV" sur E37:E76 => somme en G37:G76

PLEASE HELP!!! totalement impossible pour moi de trouver la formule...
Merci pour vos conseils avisés.

bonne journée.
Agathe
Afficher la suite 

Votre réponse

3 réponses

Messages postés
10518
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 avril 2019
1383
0
Merci
Bonjour

Essaie :
=SOMME.SI.ENS(G37:G76 ;B37:B76;"PREMIUM";E37:E76;"TV")

Cdlmnt
Via
ALLELIUA!!!! you made my day. merci mille fois de Guadeloupe. vive internet;))
Commenter la réponse de via55
Messages postés
48610
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 avril 2019
16107
0
Merci
Bonjour, chère voisine et compatriote !

Pour illustrer la formule de mon fidèle ami Via, voici un classeur dans lequel j'utilise des listes déroulantes de cellule à la fois pour renseigner la plage B37:B76 et la plage E37:E76 et pour choisir en D3 et D4 les critères de calcul pour D5.
https://www.cjoint.com/c/IDkvYvvXbSO
Si tu rencontres une difficulté, tu nous demandes ...
Commenter la réponse de Raymond PENTIER
0
Merci
Bonjour Raymond,

Merci pour votre précieuse aide. Votre fichier m aide bcp. Je vais l'ameliorer de ce pas sur vos précieux conseils.

Merci bcp, cher voisin;)
bonne journée!
Commenter la réponse de agathe