Menu

Fonction "renvoyer l'ordre d'apparition" [Résolu]

Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
- - Dernière réponse : Coco-8
Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
- 10 avril 2019 à 15:59
Bonjour à tous,

Je souhaiterais trouver une formule me permettant de me renvoyer le rang de plusieurs valeurs mais pas par ordre décroissant comme le fait la fonction RANG mais par ordre d'apparition. Exemple :


Dans mon tableau de droite, j'aimerais obtenir pour chaque référence leur ordre d'apparition dans la plage A2:F2. Dans l'exemple, la première référence qui est différente de 0 est le C (donc C=1), la deuxième est D (donc D=2) et la troisième est F (donc F=3).

Merci de votre aide :)
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23852
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 avril 2019
5759
0
Merci
Bonjour
Pas sur que ce soit ce que vous voulez mais au pied de la lettre, pour obtenir votre tableau en H2:M2, il suffit d'entrer en H2 cette formule:

=SI(A2>0;MAX($G$2:G2)+1;"")

et de tirer vers la droite
attention au signe$
crdlmnt
Coco-8
Messages postés
75
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
15 avril 2019
1 -
Parfait ça marche, merci beaucoup !
Entre temps j'avais trouvé une autre solution qui se rapproche de la tienne avec NB.SI à la place de MAX comme tu me le proposes, mais ma solution posera problème si jamais je dois rajouter des références alors qu'avec la tienne je devrai simplement étirer vers la droite.

Donc merci :)
Commenter la réponse de Vaucluse