Menu

Somme feuille à feuille avec plusieurs critères

Messages postés
56
Date d'inscription
vendredi 25 août 2017
Statut
Membre
Dernière intervention
25 avril 2019
- - Dernière réponse : Vaucluse
Messages postés
23880
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
- 10 avril 2019 à 14:15
Bonjour,
Je suis sur la feuille F1 et je cherche à faire la somme dans la feuille F2 des valeurs de la colonne C avec les critères "1" à "12" contenus dans la colonne B et représentant les différents mois de l'année.
Est-il possible d'écrire une suite de critères (1 à 3 par exemple) ou faut-il citer tous les critères dont on a besoin ?
Merci pour votre assistance

Cordialement
Fat
Afficher la suite 

Votre réponse

1 réponse

Messages postés
23880
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 avril 2019
5769
0
Merci
Bonjour
=SOMMEPROD((Feuil2!B1:B1000>=12)*(Feuil2!C1:C1000))
avec ce code mieux vaut limiter le nombre de lignes dans les adresses il est assez lourd
vous avez aussi:
=SOMME.SI(Feuil2!C:C;Feuil2!B:B;">=12")
mais avez vous autre chose que 1 à 12 dans la colonne B ???

et en variante pour limiter les périodes, soit uniquement le N° du mois, soit une combinaison du genre (pour 1 à 3):

=SOMMEPROD((Feuil2!B1:B1000>=1)*(Feuil2!B1:B1000<=3)*(Feuil2!C1:C1000))

ou:(à partir de 2013)

=SOMME.SI.ENS(Feuil2!C:C;Feuil2!B:B;">=1";Feuil2!B:B;"<=3")

et si vous placez les limites dans des cellules exemple Z1 Z2:

=SOMME.SI.ENS(Feuil2!C:C;Feuil2!B:B;">="&Z1;Feuil2!B:B;"<="&Z3)
attention aux signes
crdlmnt



crdlmnt

Commenter la réponse de Vaucluse