Menu

Erreur dans une formule [Résolu]

Messages postés
26
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
12 avril 2019
- - Dernière réponse : Vaucluse
Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
- 10 avril 2019 à 16:48
Bonjour,

je cherche à calculer dans le tableau ci-joint, le nombre de séances par mois et par sport.

https://www.cjoint.com/c/IDjqKFaRKW2

L'erreur semble venir du dernier critère de cette formule:
=NB.SI.ENS($A$2:$A$10000;">31/12/2018";$A$2:$A$10000;"<01/02/2019";$D$2:$D$10000;"=1";C2:C10000;"=I2").

Pour Tennis/Janvier, je devrais avoir "1". 1 séance le 01/01/2019.

Pour infos quand une même date concerne le même sport, il s'agit de la même séance.

Par avance merci,
Afficher la suite 

Votre réponse

1 réponse

Meilleure réponse
Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
5763
1
Merci
Bonsoir
supprimer les guillemet à la fin, ils sont contrariants quand on s'adresse à une valeur numérique ou a une cellule:

($A$2:$A$10000;">31/12/2018";$A$2:$A$10000;"<01/02/2019";$D$2:$D$10000;1;$C$2:$C$10000;I2)

(et n'oubliez pas de bloquer le C2:C10000 avant de tirer la formule

crdlmnt

ps: votre formule suppose que chaque personne ne fait pas plus d'un tennis par mois?

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40431 internautes nous ont dit merci ce mois-ci

badarledur
Messages postés
26
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
12 avril 2019
-
Bonjour,

merci pour la réponse. Maintenant ça fonctionne!

réponse au ps:
Chaque personne peut faire plus d'un tennis par mois.
En février, Pierre participe aux deux séances de tennis.
Vaucluse
Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
5763 -
Je me suis mal expliqué dans ma remarque. La question était de savoir si dans la colonne D il pouvait y avoir autre valeur que 1 (des deux, trois ou autre). Dans ce cas ces valeurs ne sont pas comptées par la formule
crdlmnt
badarledur
Messages postés
26
Date d'inscription
jeudi 1 janvier 2009
Statut
Membre
Dernière intervention
12 avril 2019
-
Ah ok.

Non cette colonne ne peut comprendre que des "1".

Cordialement,
et merci pour l'aide!
Vaucluse
Messages postés
23868
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 avril 2019
5763 -
Pas de quoi
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse