Menu

Formule si et si [Résolu]

- - Dernière réponse :  lilitartine - 9 avril 2019 à 16:10
Bonjour,

Please, j'ai besoin de votre aide et de votre expertise d'expert :).
Ma question est la suivante j'ai besoin d'une formule multiple
J'ai besoin de faire une pyramide des âges et des catégoriser les âges
Les âges sont en colonne I les catégories devront s'intégrer automatiquement en colonne J
cela donne : SI entre 20 et =30 alors CAT1 ET SI entre 31 et =35 CAT2 ET SI entre 36 et =40 CAT3 ET SI entre 41 et 45 CAT4 ET SI entre 46 et 50 CAT 5 ET SI entre <51 CAT6
J'ai bien réussi à faire ma formule 1 : =SI(ET(I2<=20;I2<=30);"CAT1") mais je n'arrive pas à aller plus loin
Par avance, merciiiiiii
Emilie
Afficher la suite 

Votre réponse

2 réponses

Messages postés
1722
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 avril 2019
639
0
Merci
Bonjour,

Dans votre cas c'est plutôt des Si imbriquées pas besoin de fonction et sauf pour la première condition ( comme le suppose votre titre)

=Si(et(I2>=20;I2<=30);"CAT1";Si(I2<=35;"CAT2";Si(I2<=40;"CAT3";SI(I2<=45;"CAT4";SI(I2<=50;"CAT5";"CAT6")))))

Comme il n'y a pas de précision pour inférieur à 20 je n'ai rien mis.
MERCI C'est PARFAIT cela semble fonctionner !:)
Merci d'avoir été rapide !
Diablo, avez-vous vu ma seconde question ?
j'ai de nouveau le même problème j'ai voulu faire la formule mais aie il me dit #nom j'ai 4 catégories
CAT1 1-7
CAT2 8-15
CAT3 16-25
CAT4 +25
j'ai fait cette formule
=SI(Q1="";"";"CAT"&SI(Q1<=7;1;SI(Q1<=15;2;SI(Q1<=25;3;SI(Q1>=25;4)))))
cane marche pas…
j'ai teté ca aussi : =SI(ET(Q1>=0;Q1<=7;"CAT1";SI(Q1=8;Q1<=15;"CAT2";SI(Q1=16;Q1<=25;"CAT3";SI(Q1>25;"CAT4")))
Commenter la réponse de diablo13800
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764
0
Merci
Bonjour
il devrait suffire de placer les conditions dans l'ordre, la première réalisée éliminant les suivantes

=SI(I2="";"";SI(I2<=30;"CAT1";SI(I2<=35;"CAT2";SI(I2<=40;"CAT3";SI(I2<=45;"CAT4";SI(I2<=50;"CAT5";"CAT6"))))))

ou pour raccourcir un peu:

=SI(I2="";"";"CAT"&SI(I2<=30;1;SI(I2<=35;2;SI(I2<=40;3;SI(I2<=45;4;SI(I2<=50;5;6))))))

crdlmnt

diablo13800
Messages postés
1722
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 avril 2019
639 -
Alors... non la vous avez juste détruis une formule... Vous ne pouvez pas écrire si(Q1=0;<=7;1), ça veut juste rien dire en formule.
Les formules apportées par Vaucluse ou moi fonctionne correctement. Plutôt que nous dire " Ça marche pas " dites nous les valeurs que vous avez testez avec nos formules, et on pourra peut être dire pourquoi... et comment corriger.
j'aimerais avoir dans ma colonne R s'affiche directement
CAT1 compris entre 0-7
CAT2 compris entre 8-15
CAT3 16-25
CAT4 +25
en fonction de ma colonne Q1
si 13 en Q = CAT2 en R
si 1 en Q = CAT1 en R
etc.
Vaucluse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764 -
Alors vous devriez déposer ici un modèle de votre fichier qui doit être un eu spécial
voyez sur:
http://mon-paratge.fr
et revenez coller le lien que vous aurez créé sur le site
en attendant voyez ici avec la formule:
https://mon-partage.fr/f/B3m4EOr3/
je me sauve, mais notre ami DIABLO va vous régler ça sans problème
crdlmnt
diablo13800
Messages postés
1722
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
19 avril 2019
639 -
Le lien de Vaucluse est faux pour partager votre fichier
Il s'agit de :
http://mon-partage.fr

Une petite faute de frappe s'est immiscé
Vaucluse, effectivement dans votre doc cela fonctionne.. Rha !
Du coup j'ai bidouillé j'ai créé des colonnes dans mon doc, copier-coller votre formule, suprimé, et tout et tout et ca MARCHE ! YOUPI ! je suis sur ce doc RH depuis ce matin MERCIIII a vous deux E
Commenter la réponse de Vaucluse