Menu

Recherche valeurs selon date dans un tableau [Résolu]

- - Dernière réponse : Vaucluse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
- 9 avril 2019 à 15:36
Bonjour,

Je cherche la formule correct pour afficher les résultats des certaines cellules en fonction de la date dans mon tableau, sachant que ma date prend 3 cases, le résultat cherché est dans la 3 ème case.


2 ème précision, je masque la date du jour systématiquement (je travail pour le lendemain) question bonus, est il possible de masquer la date à l'ouverture du classeur ?

Voici le lien pour mieux comprendre ma demande avec un petit fichier d'exemple.

Merci de m'avoir lu, et d'avance pour vos éventuelles réponses.

https://www.cjoint.com/c/IDjadqKjk6j

Bien à vous.

Nico.

Configuration: Windows / Chrome 73.0.3683.86
Afficher la suite 

Votre réponse

2 réponses

Meilleure réponse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764
1
Merci
Bonjour
avec cette formule en D4 à tirer sur les trois cases:

pour ressortir la valeur seul
=INDEX(E4:S4;EQUIV($B$2;$E$3:$S$3;0)+2)

pour ressortir la somme jusqu'à la date:
=SOMMEPROD(($E$3:$Q$3<=$B$2)*($E$3:$Q$3>0)*(G4:S4))
crdlmnt

=

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 40432 internautes nous ont dit merci ce mois-ci

Bonjour Vaucluse,

J'ai recopié la 1ere formule mais j'obtenais un NA# j'ai donc modifier par

=INDEX(E3:S3;EQUIV($B$2;$E$2:$S$2;0)+2)

Et le résultat est exactement ce que je voulais, je vais donc l'appliquer à mon classeur final !

Je peux donc continuer de travailler grâce à toi !!

Merci beaucoup!
Vaucluse
Messages postés
23870
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
5764 -
effectivement, je me suis trompé de ligne dans une maquette que j'avais montée
bien vu
je passe en résolu
Bonne route
crdlmnt
Commenter la réponse de Vaucluse
0
Merci
J'ai modifier le fichier car les 2 colonnes non coloré sont additionner en somme dans la 3ème cellule.

Ci dessous:


https://www.cjoint.com/c/IDjbyGR6W8j

Bien à vous.

Nico
Commenter la réponse de nico