Menu

Fonction RechercheV ou autre [Résolu]

Messages postés
5
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
- - Dernière réponse : hamid.33
Messages postés
5
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
- 9 avril 2019 à 19:24
Bonjour à tous,

Je recherche désespérément la manipulation à faire pour que excel aille me chercher des données dans un tableau. Je sais faire quand il n'y a qu'une seule donnée avec la fonction RECHERCHEV. Mais dès qu'il y a 2 possibilités pour une recherche, excel choisit que le premier. Help les amis.

le modèle du fichier se trouve ici:

https://transfernow.net/a638ba825mk4

Merci.
Afficher la suite 

Votre réponse

4 réponses

Messages postés
48632
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
16115
0
Merci
Mais ... c'est tout-à-fait normal !
C'est même le principe de base de fonctionnement de RECHERCHEV.
hamid.33
Messages postés
5
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
Ok merci Mr Pentier.
Commenter la réponse de Raymond PENTIER
Messages postés
48632
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 avril 2019
16115
0
Merci
Il te suffit d'appliquer un filtre à la colonne I, et tu auras affichées uniquement les lignes correspondant à Nicolas.
hamid.33
Messages postés
5
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
ok, je testerai sa après le boulot.
Merci de m'avoir accorder de votre temps.
Commenter la réponse de Raymond PENTIER
Messages postés
16874
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 avril 2019
5094
0
Merci
Bonsoir,

RECHERCHEV renvoi la première valeur rencontrée, et ne convient pas pour un renvoi multiple.
plusieurs possibilités avec colonne intermédiaire ou une formule plus compliquée pour un renvoi direct

=SI(LIGNES($1:1)<=NB.SI($I$5:$I$24;$A$10);INDEX($J$5:$J$24;EQUIV($A$10;$I$5:$I$24;0)+LIGNES($1:1)-1;0);"")

si tu nommes tes plages la formule se simplifie, exemple la plage $I$5:$I$24 nommée Nom et la plage $J$5:$J$24 nommée Num
la formule devient
=SI(LIGNES($1:1)<=NB.SI(Nom;$A$10);INDEX(Num;EQUIV($A$10;Nom;0)+LIGNES($1:1)-1;0);"")

et sans rien changer peut être utilisée sur des onglets différent
ensuite incrémenter la formule vers le bas
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
hamid.33
Messages postés
5
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
-
D'accord, merci je vais testé sa après le boulot. Merci encore.
Commenter la réponse de Mike-31
Messages postés
5
Date d'inscription
lundi 8 avril 2019
Statut
Membre
Dernière intervention
9 avril 2019
0
Merci
Bonsoir et merci à Vaucluse car sa fonctionne super bien.

Merci à tout le monde de m'avoir accorder un peu de votre temps.
Bonne soirée tout le monde.
Commenter la réponse de hamid.33